The default bug view has changed. See this FAQ.

Sending unsent messages gives ugly entry in Activity Manager

RESOLVED FIXED in Thunderbird 46.0

Status

Thunderbird
Mail Window Front End
--
trivial
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Jorg K (GMT+1), Assigned: Jorg K (GMT+1))

Tracking

Trunk
Thunderbird 46.0

Thunderbird Tracking Flags

(thunderbird45 fixed, thunderbird46 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

a year ago
Created attachment 8708780 [details]
Screenshot showing the ugly default item and the text "null".

Sending unsent messages gives ugly entry in Activity Manager:

STR:
Compose a message. Press <CTRL><SHIFT><ENTER> to send the message to the outbox.

From the file menu select "Send Unsent Messages". Then check the Activity Manager. What you see there is ugly, see attachment.

By the looks of it, an icon is missing. Also, the text "null" is not helpful.
(Assignee)

Comment 1

a year ago
Oh, it works almost as designed apart from the "null" display:
https://dxr.mozilla.org/comm-central/source/mail/components/activity/modules/sendLater.js#128
event.iconClass = "sendMail";
And the sendMailIcon.png is this funny stamp icon.
OK, maybe I'll remove the "null" then.
Severity: minor → trivial
Same happens here. For the icons we'd need a graphic artist to make better ones.

What do you use to open the activity manager in a tab?
(Assignee)

Comment 3

a year ago
(In reply to Richard Marti (:Paenglab) from comment #2)
> What do you use to open the activity manager in a tab?
Oh, you noticed. That's a secret ;-) OK, since it's Sunday:
<profile>\chrome\userChrome.js has
if (location == "chrome://messenger/content/messenger.xul") {
  document.getElementById("activityManager").setAttribute("oncommand",
    "openContentTab('chrome://messenger/content/activity.xul');");
}
and http://downloads.mozdev.org/userchromejs/userchromejs-2.0-sm+tb+fx.xpi
(Assignee)

Comment 4

a year ago
Created attachment 8708795 [details] [diff] [review]
Trivial fix.

Aceman, trivial change. Thanks for the review ;-)
Attachment #8708795 - Flags: review?(acelists)
(Assignee)

Updated

a year ago
Assignee: nobody → mozilla
Status: NEW → ASSIGNED

Comment 5

a year ago
Comment on attachment 8708795 [details] [diff] [review]
Trivial fix.

Review of attachment 8708795 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me. Just update the commit message to say about the sendLater event. Currently it looks like you do it for all events.
Attachment #8708795 - Flags: review?(acelists) → review+
(Assignee)

Comment 6

a year ago
Created attachment 8708825 [details] [diff] [review]
Trivial fix. (v2 with improved checkin comment).
Attachment #8708795 - Attachment is obsolete: true
Attachment #8708825 - Flags: review+
(Assignee)

Updated

a year ago
Keywords: checkin-needed
(Assignee)

Comment 7

a year ago
Comment on attachment 8708825 [details] [diff] [review]
Trivial fix. (v2 with improved checkin comment).

[Approval Request Comment]
Regression caused by (bug #): No regression.
User impact if declined: None.
Testing completed (on c-c, etc.): Manual testing.
Risk to taking this patch (and alternatives if risky):
None whatsoever. Changed null to "" in one call.
Attachment #8708825 - Flags: approval-comm-aurora+

Comment 8

a year ago
https://hg.mozilla.org/comm-central/rev/53b84f8641a8a0b46473177cb4b08031a8c3e55c
Bug 1240366 - Pass an empty string instead of null as status when creating a new activity event in onMessageSendProgress. r=aceman

Updated

a year ago
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 46.0
(Assignee)

Comment 9

a year ago
Aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/c38ce757de5b
status-thunderbird45: --- → fixed
status-thunderbird46: --- → fixed
You need to log in before you can comment on or make changes to this bug.