Closed Bug 1240370 Opened 5 years ago Closed 5 years ago

Nightly crashes in an attempt to print out a page with Microsoft XPS Document Writer

Categories

(Core :: Printing: Output, defect)

46 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1156742

People

(Reporter: r_kato, Unassigned)

Details

(Keywords: crash)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160116030240

Steps to reproduce:

The latest Nightly (2016-01-16) on x86_32 Windows 7

1. On any page, hit Ctrl+P to open a Print dialog.
2. Select "Microsoft XPS Document Writer" as a printer, then click OK.
3. If Save as... dialog is popped up, then specify a file name and click OK.


Actual results:

Nightly crashes. Also, processing between step 2 and step 3 takes a little time.

A similar issue has been reported as 818446 about 3 years ago.


Expected results:

Specified .xps file should be printed out without a crash.
Nightly crashes only. Firefox 45 below doesn't crash.

A similar issue is Bug 818446.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86
I see a input box and the not wroks when e10s on, works fine when e10s off, on Windows 10.


Could you provide a crash ID?
https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report.
Severity: normal → critical
Component: Untriaged → Printing: Output
Flags: needinfo?(foobar094)
Keywords: crash
Product: Firefox → Core
(In reply to YF (Yang) from comment #2)

I reproduced this bug with the e10s enabled latest Nightly (2016-01-07) on Windows 7. But I cannot do when e10s disabled.

Here is the crash ID.
bp-680494c3-be7a-43d2-a627-ba53e2160117

Thanks!
Flags: needinfo?(foobar094)
It's another variant of bug 1156742.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1156742
You need to log in before you can comment on or make changes to this bug.