moz-extension:// procotol url hashtag #!/foo 404

RESOLVED DUPLICATE of bug 719905

Status

()

Toolkit
WebExtensions: Untriaged
P4
normal
RESOLVED DUPLICATE of bug 719905
2 years ago
10 months ago

People

(Reporter: zzt, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2227.1 Safari/537.36
Build ID: 20151229124331



Actual results:

If a moz-extension:// procotol url hashtag contains an leading exclamation mark, the file won't be accessible. 

The chrome-extension:// protocol supports exclamation marks, however.

Example:
moz-extension://uuid/test.html#foo (works)
moz-extension://uuid/test.html#/foo (works)
moz-extension://uuid/test.html#!/foo (404)
moz-extension://uuid/test.html#$/foo (works)

Tested with:
Firefox Developer Edition 45.0a2 (2016-01-16)
Google Chrome 47.0.2526.106


Expected results:

The moz-extension:// procotol should follow the RFC 1738 specification.
(Reporter)

Comment 1

2 years ago
Created attachment 8708799 [details]
firefox-dev-edition-45-0a2-linux_x64.png
(Reporter)

Comment 2

2 years ago
Created attachment 8708800 [details]
log.txt

Updated

2 years ago
Priority: -- → P4
Whiteboard: [good first bug] triaged
Whiteboard: [good first bug] triaged → triaged
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 719905

Comment 4

10 months ago
(In reply to Kris Maglione [:kmag] from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 719905 ***

Current bug is not resolved

My extension is a single web-page application created with angular js.

The problem is that i've got "404 File not found" error when i'm using link with angular route

for example i'll get an error if I will use this link

moz-extension://76322ca6-cae1-c54b-8484-d69fea2c788f/index.html#!/dashboard
but it works if i'll use it without route

moz-extension://76322ca6-cae1-c54b-8484-d69fea2c788f/index.html

This problem takes place only with packed extension. 
Unpacked extension works fine.
You need to log in before you can comment on or make changes to this bug.