click on button 'get next X jobs' adds a duplicate results check as interval

RESOLVED FIXED

Status

Tree Management
Treeherder
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aryx, Assigned: aryx)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

Created attachment 8708829 [details] [review]
[treeherder] Archaeopteryx:bug1240391-updateIntervalAppend > mozilla:master
Created attachment 8708830 [details] [review]
pull request, v1
Attachment #8708830 - Flags: review?(emorley)

Comment 3

2 years ago
Comment on attachment 8708830 [details] [review]
pull request, v1

Good spot and thank you for the PR. Cameron knows this code better than I, so redirecting :-)
Attachment #8708830 - Flags: review?(emorley) → review?(cdawson)
Comment on attachment 8708830 [details] [review]
pull request, v1

Made a note in the PR, but this change would have the effect that clicking a "next" button would load more resultsets with no jobs.

I'm actually not able to reproduce the problem you're referring to.  I only see 1 call to the /resultsets/ endpoint per poll interval no matter how many times I click a "next X" button.  We DO add more /jobs/ endpoint pollers because we have to have a poller for each resultset to get any new jobs that have been created.

Would you be able to provide more information on what you're seeing?  Thanks!  :)
Attachment #8708830 - Flags: review?(cdawson) → review-
ahh, ok. So it looks like the issue is that it's duplicating the job pollers.  Yeah, I'm seeing that too.  Perhaps a check needs to be added to see if there is already a job poller and not add a anew one in that case.  You may not need your param at all.
Created attachment 8714399 [details] [review]
[treeherder] Archaeopteryx:bug1240391-updateIntervalAppend > mozilla:master
Comment on attachment 8714399 [details] [review]
[treeherder] Archaeopteryx:bug1240391-updateIntervalAppend > mozilla:master

Nice!  This works great!  Thanks for the patch.  :)
Attachment #8714399 - Flags: review?(cdawson) → review+

Comment 9

2 years ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/d1d213ac770355fbb8c67abf572169e2dac4ab44
Bug 1240391 - 'Get next X jobs' shouldn't create additional job pulling interval

https://github.com/mozilla/treeherder/commit/937fba1a2da220c8f738b1127773fe653fead1dd
Merge pull request #1289 from Archaeopteryx/bug1240391-updateIntervalAppend

Bug 1240391 - 'Get next X jobs' shouldn't create additional job pulling interval

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.