Closed Bug 1240395 Opened 4 years ago Closed 3 months ago

Location bar doesn't display suggestions when I type a symbol after pressing Escape twice

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox46 --- affected

People

(Reporter: arni2033, Unassigned)

References

Details

(Whiteboard: [fxsearch])

>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160116030240
STR:
1. Open http://example.org/
2. Click in urlbar to select all text there
3. Type "a" without quotes
4. Press Escape to collapse suggestions
5. Press Escape to reset the string in urlbar to "example.org"
6.A) Type "a" without quotes
6.B) Type "b" without quotes
6.C) Type "c" without quotes

Result:
 (A) - suggestions aren't shown.   (B) and (C) - suggestions are shown.

Expectations:
 Either X or Y. The only logical expectations I came up with.
 X) Suggestions should always show after Step 6.
 Y) Suggestions should always not show because I collapsed suggestions list for some reason.
    That means that I somehow don't want it, so I expect it to only show when I press Up/Down.
Is this still reproducible? I couldn't reproduce so far
Flags: needinfo?(arni2033)
(In reply to Marco Bonardo [::mak] from comment #1)
> Is this still reproducible? I couldn't reproduce so far
Please read section (1) which I need asap; section (2) isn't necessary

1) Unfortunately it appears that this bug is the same as bug 1254416 (as filed). I think that I mixed
   up bugs in this case, because I now see that I have pending bug report with the same STR that says
  [*]  "Location bar doesn't autofill when I typed a symbol/paste text after pressing Escape twice"

   I think that the same mechanism is involved in [*] and bug 1254416, so I'd like to: hide irrelevant
   comments such as this comment and comment 0, then put STR,AR,ER of bug [*] into "User story"
   section, then set this bug as dependent on 1254416. The other option is to mark this as duplicate
   of 1254416, so I'll have to file [*] separately, which I don't want. NI for your opinion.

2) I'm facing ambiguous comments from Mozilla devs, saying "still couldn't reproduce"...
   It's unclear what's meant in each case, because "still"/"so far" can mean
  "I tried to reproduce this a month ago, failed, and today (2nd attempt) I can't reproduce too" or
  "I just tested reported version (reliable way of testing) 2 times 1 minute ago and failed".
   And also those comments don't mention any exact version.
  (I just thought you might want to know how foreign people read your comments. If this observation
   is only caused by the fact that I'm not a native speaker, ignore this section (2))
Flags: needinfo?(arni2033) → needinfo?(mak77)
(In reply to arni2033 from comment #2)
>    It's unclear what's meant in each case, because "still"/"so far" can mean
>   "I tried to reproduce this a month ago, failed, and today (2nd attempt) I
> can't reproduce too" or

That's usually the meaning. We do periodic triage of the unprioritized bugs to see if they are actionable.

>    And also those comments don't mention any exact version.

It's the latest Nightly, when not specified.

Re 1) let's just add a dependency, that is also nicer for QA purposes.

If you can tag comments (don't recall which permission is required) you can tag them as obsolete, and that should hide them.
Depends on: 1254416
Flags: needinfo?(mak77)
Priority: -- → P3
Whiteboard: [fxsearch]

This bug is a little hard to follow due to comment 2, but I've tried 3 different STR that I think cover everything, and Firefox behaves as expected, so I'm going to close this. Please reopen if I'm mistaken.

For quantumbar, we no longer ignore consecutive searches for the same string like we used to, and I think that's the main thing that fixed this (which is also what Marco said in bug 1254416 comment 4).

STR 1:

  1. Visit http://example.org/
  2. Click in the urlbar to select all text.
  3. Type "a". addons.mozilla.org/ is autofilled.
  4. Press Esc. The popup closes.
  5. Press Esc again. The text is reverted to example.org.
  6. Type "a". addons.mozilla.org/ is autofilled and the popup opens with a search for "a".
  7. Type "b". The popup shows a search for "ab".
  8. Type "c". The popup shows a search for "abc".

STR 2:

  1. Visit http://example.org/
  2. Click in the urlbar to select all text.
  3. Type "a". addons.mozilla.org/ is autofilled.
  4. Press Esc. The popup closes.
  5. Press Esc again. The text is reverted to example.org.
  6. Type "e". example.org/ is autofilled and the popup opens with a search for "e".

STR 3:

  1. Visit http://example.org/
  2. Click in the urlbar to select all text.
  3. Type "e". example.org/ is autofilled.
  4. Press Esc. The popup closes.
  5. Press Esc again. All text is selected.
  6. Type "e". example.org/ is autofilled and the popup opens with a search for "e".
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.