when looking at two different revisions highlighted in a perfherder graph, I would like to see different colors for the highlights

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
I have found in using perfherder graphs and have revA and revB highlighted, I am not sure if this is the revision causing the regression or not.  I have to look at each revision by itself.  

We usually add both revisions to the highlight list from the compareview.  This is useful and helpful, but I would like to highlight colors:
revA: green
revB: red

we can highlight the revision in the text as well as the specific dots that we highlight/bold.
(Reporter)

Comment 1

3 years ago
here is an example bit of code that solves this- it is sloppy, but worth discussing more on what we want and how to make this solved:
https://github.com/jmaher/treeherder/commit/a8b5e9f37f796adce6de93b249b6d7fbd4686d7a

:wlach, thoughts on ^ patch?
Flags: needinfo?(wlachance)
(Reporter)

Comment 2

3 years ago
here is a screenshot of what the current patch looks like:
http://people.mozilla.org/~jmaher/lines.png
I'm just not sure. :) I worry a bit that people might find this confusing. But if it would be useful to you, that's probably reason enough to put this in.

Minimum changes I would make before landing this (aside from code style issues):

1. Only show the lines if both revisions are selected.
2. Use a slightly lighter color than black, maybe #333 or so.
Flags: needinfo?(wlachance)
(Reporter)

Comment 4

3 years ago
in coming back to this I am thinking this problem would be good to solve, but the current implementation and any thoughts I have on it is not something that would be a value add.

:wlach, do you have further thoughts here?  I am fine closing as wontfix, or trying a few other things out.
Flags: needinfo?(wlachance)
Yeah, I think part of the motivation for this was being able to visualize alerts better, but some of the additional features that we've added solve that problem in a different way. Let's mark this as wontfix for now: if we think of some new ideas in the future, we can file bugs for them.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(wlachance)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.