Nightly sign in to sync page stuck on cannot create account with invalid age

RESOLVED WORKSFORME

Status

()

Firefox
Sync
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: smita.biradar12, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8708853 [details]
NightlyAccount_ErrorScreenshot.JPG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36

Steps to reproduce:

On nightly browser, select tools - sign in to sync option
Click create account
Enter email address, password and age less than 18
Click sign up



Actual results:

Displayed account cannot be created with learn more link
Tried back button, page refresh and tools - sign in to sync option
On trying all the 3 above options, always it takes us to cannot create account page until you close the browser and start from scratch


Expected results:

Expected either back button or refresh button or at least tools - sign in to sync option to work without closing the browser. 
Seems like once invalid information is entered, there is no way to correct it until you reopen the browser

Comment 1

3 years ago
I tried with the latest Nightly and e10s enabled, no issue with age less (or not) than 18.

Could you test with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(smita.biradar12)

Updated

3 years ago
Component: Untriaged → Sync
Unfortunately, I believe this is the intended behaviour.  As part of our compliance with COPPA and similar laws, once you've told us that you're under the required age limit, we can't make it too trivial to circumvent by going back and entering a different age.  We'd have to check on legal compliance if we wanted to make any changes in this area.
As :rfkelly said, for reasons outside of our control, this is the intended behaviour
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(smita.biradar12)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.