poor accessibility of 'today' coloring in Lightning month view

RESOLVED DUPLICATE of bug 964040

Status

Calendar
Calendar Views
RESOLVED DUPLICATE of bug 964040
2 years ago
2 years ago

People

(Reporter: John Pye, Unassigned)

Tracking

Lightning 4.0.4.1

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8708881 [details]
accessible-colors-ubuntu-14.04-lightning.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125222139

Steps to reproduce:

I am using Lightning 4.0.4.1 (Thunderbird 38.5.1 on Ubuntu 14.04). I have turned on the "Optimize colors for accessibility" option to make the colors a bit clearer.



Actual results:

The highlighting for today's date is really not very clear. See the left screenshot below. There is only a thin orange line and orange date "18" to highlight today's date/events. 

Further, when today's date is actually selected, there is very little to show that it is indeed today that is selected. Only the thin orange line confirms that I have selected today's date.


Expected results:

This is really hard to see clearly. These colors, even with accessibility turned on, are really not sufficiently bold or easy to see. My eyesight isn't that bad, and I still find my eyes hunting around the screen "where is today again?". It should be really obvious.

I suggest adding a much bolder highlight around today's date, and *additionally* using a distinct colour for the selection highlight.

Updated

2 years ago
Component: Lightning Only → Calendar Views

Comment 1

2 years ago
The option "Optimize colors for accessibility" is meant to be used with themes related to accessibility problems like High Contrast or Two Colors themes (see original bug 671119). Usually, when activated with normal themes, is useless or even detrimental depending on the theme.

Do you see problems with the option if you enable a High Contrast theme on your Linux platform?

Instead, if the problem is the style of the "today" day in the views (e.g. poor visibility), the reference bug is bug 964040. Please, mark this bug as duplicate in this case.
Flags: needinfo?(john)

Comment 2

2 years ago
No response from the reporter.
Based on description in expected results I think this is should be cosidered a duplicate of bug 964040.
Please change the status if is an issue about accessibility optimization instead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(john)
Resolution: --- → DUPLICATE
Duplicate of bug: 964040
You need to log in before you can comment on or make changes to this bug.