Closed Bug 1240493 Opened 9 years ago Closed 9 years ago

[Stingray][fling-player][TV][2.5] Update video backward/forward searching time

Categories

(Firefox OS Graveyard :: Gaia::TV::Fling, defect, P1)

defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
2.6 S6 - 1/29
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: Fischer, Assigned: Fischer)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick][partner-blocker])

Attachments

(1 file)

The updated video backward/forward searching time:

- long press <= 3000ms: 5 secs
- 3000ms < long press <= 6000ms: 10 secs
- long press > 6000ms: 30 secs
No longer depends on: 1202361, 1222364
Assignee: nobody → fliu
QA Whiteboard: [COM=TV Seamless Experience]
Comment on attachment 8708999 [details] [review]
[gaia] Fischer-L:bug_1240493-update-fling-player-search-time > mozilla-b2g:master

@Rex,

This patch updates video backward/forward searching time on key press as below:

- long key press <= 3000ms: 5 secs
- 3000ms < long key press <= 6000ms: 10 secs
- long key press > 6000ms: 30 secs

Thank you
Attachment #8708999 - Flags: review?(rexboy)
Comment on attachment 8708999 [details] [review]
[gaia] Fischer-L:bug_1240493-update-fling-player-search-time > mozilla-b2g:master

Looks good to me with 1 nit. See Github comment.
Attachment #8708999 - Flags: review?(rexboy) → review+
Comment on attachment 8708999 [details] [review]
[gaia] Fischer-L:bug_1240493-update-fling-player-search-time > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1240493
[User impact] if declined: User would feel difficult to control video backward/forward searching time
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: None
Attachment #8708999 - Flags: approval-gaia-v2.5?(jocheng)
Comment on attachment 8708999 [details] [review]
[gaia] Fischer-L:bug_1240493-update-fling-player-search-time > mozilla-b2g:master

Approve for TV 2.5
Attachment #8708999 - Flags: approval-gaia-v2.5?(jocheng) → approval-gaia-v2.5+
blocking-b2g: --- → 2.5+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: