Don't ship MozContacts, MozIcc, MozStkCommandEvent, etc in Firefox for Android and Desktop

RESOLVED DUPLICATE of bug 1310864

Status

()

Core
DOM: Contacts
RESOLVED DUPLICATE of bug 1310864
3 years ago
2 years ago

People

(Reporter: nalexander, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
This ticket is motivated by Bug 1193431, which aims to remove permissions and bad Fennec front-end code for the Contacts API.  Unfortunately, the DOM implementation of contacts leads to a chain of dependencies that aren't properly guarded by MOZ_B2G or MOZ_RIL or whatever is appropriate, and therefore can't be turned off in Fennec (or in Desktop).  This ticket tracks at *least* getting dom/contacts and dom/icc out of Fennec, but I'd really like to see a re-thinking of what we ship in Fennec and in Desktop.  The WebApp runtime was to be removed from Fennec yesterday; we should ride this momentum to remove the huge number of moz-prefixed APIs that arose in the b2g era and are never going to be exposed to the web.  (And now, to "certified" apps, or the equivalent.)
(Reporter)

Updated

3 years ago
Component: General → DOM: Contacts
Product: Firefox for Android → Core
(Reporter)

Comment 1

3 years ago
fabrice: can you assign this to whoever can do the minimal ask I lay out in Comment 0?  Thanks!
Flags: needinfo?(fabrice)
Flags: needinfo?(fabrice)
Depends on: 1284283

Updated

2 years ago
Depends on: 1301317
Removed by bug 1310864
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1310864
You need to log in before you can comment on or make changes to this bug.