Firefox crashing when rendering canvas

RESOLVED WORKSFORME

Status

()

Core
Canvas: 2D
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: me, Unassigned)

Tracking

({crashreportid})

43 Branch
crashreportid
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

1. Open https://cryptowat.ch
2. Drag the candlestick chart back-and-forth horizontally
3. After doing this for 20-60 seconds, Firefox will crash




Actual results:

Firefox crashes with "EXC_BAD_ACCESS / KERN_INVALID_ADDRESS".

I *think* this is an issue with canvas, since canvas rendering is most of the work being done when the chart is dragged around like that. However I am not experienced enough debugging crashes like this to pinpoint where in the JavaScript code the crash actually originates.


Expected results:

Firefox should not have crashed, and in fact it seems this only started to happen in Firefox 43.
(Reporter)

Comment 1

3 years ago
I am unable to reproduce this in Firefox 42, but it consistently crashes in 43. I have gotten reports of the same from several users of the Cryptowatch website.
I've been unable to reproduce this with Firefox Nightly 46.0a1 on my 2013 Retina Macbook Pro 13". Please test this with the latest Nightly to see if it reproduces. If it does, please provide the IDs for any crashes you reported from about:crashes and a copy of your about:support page. Thanks.
Keywords: crashreportid
Whiteboard: [gfx-noted]
(Reporter)

Comment 3

3 years ago
I just tried and couldn't reproduce on Nightly. Tried again on 43 and it crashed almost immediately. I'll test on Nightly before making bug reports from now on. Thanks a lot for the quick response! I appreciate it.
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(In reply to me from comment #3)
> I just tried and couldn't reproduce on Nightly.

Does turning multi-process off in Nightly enable you to reproduce the crash?
You need to log in before you can comment on or make changes to this bug.