JSON.parse error on npm registry

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 months ago

People

(Reporter: jsantell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When viewing this page: https://registry.npmjs.org/pm2
I get the following error displayed: SyntaxError: JSON.parse: unterminated string at line 1 column 360043 of the JSON data

It's displayed as JSON-ish text in Chrome, and curl'ing it down returns a string parseable via JSON lint, so it works elsewhere. The response in the netmonitor shows a strange hash, but does have Content-Type application/json. Not sure what's up.
Weird, in Nightly I'm able to see it via the Network panel without errors.  We should get this fixed.
This works for me today and today is a Monday...
I can't seem to reproduce this anymore, not sure what the issue was but it appears to be gone now.  Going to close this out for now, if you see it again we can reopen this when we have more information or STR.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.