Closed Bug 1240671 Opened 4 years ago Closed 4 years ago

Move FINAL_TARGET_PP_FILES and TEST_HARNESS_FILES to the misc tier

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox46 fixed)

RESOLVED FIXED
mozilla46
Tracking Status
firefox46 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file, 1 obsolete file)

I think it should just work these days.
Fun. It doesn't fail the build, but several files are not installed because misc is skipped for some directories where files are copied with INSTALL_TARGETS/PP_TARGETS in Makefile.in.
Summary: Move INSTALL_TARGETS and PP_TARGETS to misc instead of libs by default → Move FINAL_TARGET_PP_FILES and TEST_HARNESS_FILES to the misc tier
This, however, works.
Attachment #8709306 - Attachment is obsolete: true
Attachment #8709306 - Flags: review?(gps)
Attachment #8709321 - Flags: review?(gps)
Blocks: 1239217
Comment on attachment 8709321 [details] [diff] [review]
Move INSTALL_TARGETS and PP_TARGETS to misc instead of libs by default

Review of attachment 8709321 [details] [diff] [review]:
-----------------------------------------------------------------

Was the change to XPI_NAME's tier intended?
Attachment #8709321 - Flags: review?(gps) → review+
(In reply to Gregory Szorc [:gps] from comment #4)
> Was the change to XPI_NAME's tier intended?

It was intended, but I'll leave it to a separate bug.
https://hg.mozilla.org/mozilla-central/rev/67e23ec18a27
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.