Change the URL pattern for localized article version under "This document has already been translated to the following locales:"

RESOLVED DUPLICATE of bug 1051539

Status

support.mozilla.org
Localization
RESOLVED DUPLICATE of bug 1051539
2 years ago
2 years ago

People

(Reporter: vesper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Example URL: https://support.mozilla.org/en-US/kb/sync-your-firefox-bookmarks-and-browsing-history-i/locales?utm_campaign=wiki-ready-l10n&utm_medium=email&utm_source=notification

Current behaviour:

The second section of the page ("This document has already been translated to the following locales:") is rendered with links like https://support.mozilla.org/fr/kb/sync-your-firefox-bookmarks-and-browsing-history-i/history - which results in a 404

Expected behaviour:

The second section of the page ("This document has already been translated to the following locales:") is rendered with links:

- for registered & logged in contributors: https://support.mozilla.org/fr/kb/sync-your-firefox-bookmarks-and-browsing-history-i/edit#preview

- for anyone who is not logged in: https://support.mozilla.org/fr/kb/sync-your-firefox-bookmarks-and-browsing-history-i/
Is the issue here that the link is a 404? We have bug 1051539 to make the link that is in place resolve correctly instead of 404ing. Or do you want this to go to the edit page anyways?
(Reporter)

Comment 2

2 years ago
If https://bugzilla.mozilla.org/show_bug.cgi?id=1051539 is easier to solve than https://bugzilla.mozilla.org/show_bug.cgi?id=1240688, I'm fine with making this bug a duplicate and resolving the earlier one.
I think the solution to bug 1051539 is more robust and will fix more problems than this bug (which is a symptom).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1051539

Comment 4

2 years ago
Hello guys,
The issue is still up.. 

For example, when I open this link - https://support.mozilla.org/pt-PT/kb/how-can-i-get-help-my-x-ray-goggles-project/history - it redirects me to a "Page not found" page. So, I have to edit the url from from /history to /edit so I can translate the article.

Cheers!
You need to log in before you can comment on or make changes to this bug.