Autoland/Try options disabled if user has never pushed to MozReview via SSH

RESOLVED INVALID

Status

P2
normal
RESOLVED INVALID
3 years ago
17 days ago

People

(Reporter: Unfocused, Unassigned)

Tracking

Details

I have a review in MozReview: https://reviewboard.mozilla.org/r/30087/
The autoland/try options in the dropdown are disabled for me, with a tooltips "You do not have the required scm level to trigger a try build" & "You must have scm_level_3 access to land".

This originally made me think my account had been disabled, because I've been on leave for some time. But nope, my account is all good (see bug 1238255).

However, I did push to the MozReview repo via HTTPS (because pushing there via SSH won't work for me, bug 1096126). So I wonder if that's related.

Comment 1

3 years ago
That's exactly the problem, the association between your account and your ldap credentials is made when you push via ssh. We're planning to fix this (see Bug 1239815) - I'll leave this bug open as well since it's a lot easier for people to find when searching.
Depends on: 1239815
Priority: -- → P2
Summary: Autoland/Try options disabled when they shouldn't be → Autoland/Try options disabled if user has never pushed to MozReview via SSH
(Assignee)

Updated

3 years ago
Product: Developer Services → MozReview

Comment 2

17 days ago
MozReview is now obsolete. Please use Phabricator instead. Closing this bug.
Status: NEW → RESOLVED
Last Resolved: 17 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.