Two clicks needed to switch tabs.

RESOLVED WONTFIX

Status

SeaMonkey
Location Bar
--
minor
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: hedonist, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

Reproduction:
open up two or more tabs.  type *anything* into the URL bar in the new tab (but
don't hit enter).  click on another tab (and note that you must click *twice* to
switch to the other tab).  then click back.  URL bar once again contains the
default "about:blank" instead of whatever was entered previous to the switch.

Reproducible: Always
Steps to Reproduce:
See description

Actual Results:  two-fold:

first, as is highlighted in bug #104778, the text in the URL bar is replaced by
'about:blank'.

second, two clicks are required to switch to another tab

Expected Results:  I realize that the first isn't necessarily a bug, but the
second should behave as: 'one click' needed to switch tabs, no matter what..

On a separate note, keep up the good work!

Comment 1

16 years ago
Confirming on Linux 2002020611. Changing summary. I don't know whether this
really is a bug. The first click is to close the drop-down list of the URL bar,
the second switches the tab. Let's hear an opinion from UI-specialists.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Summary: Semi-dupe of 104778 → Two clicks needed to go switch tabs.

Comment 2

16 years ago
Correcting typo in summary..
Summary: Two clicks needed to go switch tabs. → Two clicks needed to switch tabs.

Comment 3

16 years ago
this bug is a dup of bug 66834.
(Assignee)

Comment 4

16 years ago
It is fair to work this way because selecting a tab should always display the
url that is viewed by that tab, not some hokey text you may have typed earlier.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.