Compile errors due to missing includes

RESOLVED FIXED in Firefox 46

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

unspecified
mozilla46
Points:
---

Firefox Tracking Flags

(firefox46 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

I add a new file to the gfx/layers unified build and it caused bustage:

c:/builds/moz2_slave/try-w32-mulet-0000000000000000/build/src/gfx/layers/client/ImageClient.cpp(326) : error C2664: 'void mozilla::layers::ShadowLayerForwarder::AttachAsyncCompositable(uint64_t,mozilla::layers::ShadowableLayer *)' : cannot convert argument 2 from 'mozilla::layers::ClientLayer *' to 'mozilla::layers::ShadowableLayer *'

ImageClient.cpp doesn't know that ClientLayer is a subclass of ShadowableLayer because all it has is the forward declaration in ImageClient.h
Created attachment 8709589 [details] [diff] [review]
Patch
Assignee: nobody → bugmail.mozilla
Attachment #8709589 - Flags: review?(nical.bugzilla)
There's also this one:

c:/builds/moz2_slave/try-w32-mulet-0000000000000000/build/src/gfx/layers/opengl/OGLShaderProgram.cpp(165) : error C2065: 'CompositionOp' : undeclared identifier

because OGLShaderProgram.cpp isn't including gfx/2d/Types.h.
Created attachment 8709591 [details] [diff] [review]
Part 2 - Another missing include
Attachment #8709591 - Flags: review?(nical.bugzilla)
Summary: Compile error due to missing include → Compile errors due to missing includes
Blocks: 1238042
Comment on attachment 8709591 [details] [diff] [review]
Part 2 - Another missing include

This one doesn't seem to fix the error for some reason. Stupid un-locally-reproducible unified build bustages :(
Attachment #8709591 - Flags: review?(nical.bugzilla)
Created attachment 8709599 [details] [diff] [review]
Part 2 patch

Ok, here we go.
Attachment #8709591 - Attachment is obsolete: true
Attachment #8709599 - Flags: review?(nical.bugzilla)

Updated

3 years ago
Attachment #8709589 - Flags: review?(nical.bugzilla) → review+

Updated

3 years ago
Attachment #8709599 - Flags: review?(nical.bugzilla) → review+

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e9b03a12ce6d
https://hg.mozilla.org/mozilla-central/rev/b7b536914def
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.