Add a new -block- list type to Safe Browsing

RESOLVED DUPLICATE of bug 1237198

Status

()

Toolkit
Safe Browsing
RESOLVED DUPLICATE of bug 1237198
2 years ago
a year ago

People

(Reporter: francois, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
This new type of list will act like the malware/phishing lists (applies to navigations and resource loads) but will not have any UI or user override.
(Reporter)

Comment 1

2 years ago
The implementation will be very similar to the -forbid- list type from bug 1216723:

https://hg.mozilla.org/mozilla-central/rev/d7c0dbcf2a51
https://hg.mozilla.org/mozilla-central/rev/0b2a4b521e6b
https://hg.mozilla.org/mozilla-central/rev/40245af65036
More copypasta? Would start to be time to rewrite some code to be more generic wrt possible blocklists then.
Depends on: 1253404
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
No longer depends on: 1253404
Resolution: --- → DUPLICATE
Duplicate of bug: 1237198
(Reporter)

Updated

a year ago
No longer blocks: 1237198
You need to log in before you can comment on or make changes to this bug.