Using the arrow keys to navigate through the list of accounts causes NVDA to lose focus and jump to the connect/disconnect button.

RESOLVED DUPLICATE of bug 955413

Status

Instantbird
Account manager
RESOLVED DUPLICATE of bug 955413
2 years ago
2 years ago

People

(Reporter: Kyle, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

With NVDA enabled, open the account manager. This should put you on the list of accounts. Try to use the arrow keys to navigate through the list.


Actual results:

When you attempt to move through the account list using the arrow keys, Instantbird automatically focuses on the connect or disconnect button, causing NVDA to lose it's focus in the account list. In order to return to the list, you have to shift tab twice.


Expected results:

I would think the arrow keys should move you through the list of accounts without automatically moving to the connect or disconnect buttons.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows
Hardware: Unspecified → x86

Comment 1

2 years ago
The arrow keys *do* move you through the list of accounts.

What is the exact problem here? Is some important information not being read out when switching between accounts? What is lost due to the focus being on a button? (I don't have NVDA.)
(In reply to aleth [:aleth] from comment #1)

> What is the exact problem here?

My guess is that the screen reader announces that the "connect"/"disconnect" button is focused, which is probably confusing, and unlikely to signal to someone that using the arrow keys would move the selection to another account.
(Reporter)

Comment 3

2 years ago
(In reply to aleth [:aleth] from comment #1)
> The arrow keys *do* move you through the list of accounts.
> 
> What is the exact problem here? Is some important information not being read
> out when switching between accounts? What is lost due to the focus being on
> a button? (I don't have NVDA.)

The name of the account isn't being read as we arrow through the list since the focus is instantly taken from the list view and moved to the connect button.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 955413
You need to log in before you can comment on or make changes to this bug.