Define all backends in one place

RESOLVED FIXED in Firefox 46

Status

()

Core
Build Config
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla46
Points:
---

Firefox Tracking Flags

(firefox46 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
(Assignee)

Comment 1

2 years ago
Created attachment 8709780 [details] [diff] [review]
Define all backends in one place

When adding a backend, we currently have to add them in three different
places so that they appear in the right places.

Instead, keep the list in a single place.
(Assignee)

Updated

2 years ago
Attachment #8709780 - Flags: review?(gps)
(Assignee)

Comment 2

2 years ago
Created attachment 8709784 [details] [diff] [review]
Define all backends in one place

... with the required test change.
Attachment #8709780 - Attachment is obsolete: true
Attachment #8709780 - Flags: review?(gps)
Attachment #8709784 - Flags: review?(gps)

Comment 3

2 years ago
Comment on attachment 8709784 [details] [diff] [review]
Define all backends in one place

Review of attachment 8709784 [details] [diff] [review]:
-----------------------------------------------------------------

Nice. Thank you for adding suitability checks to the backends.
Attachment #8709784 - Flags: review?(gps) → review+

Comment 4

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f7a8480e3efa

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f7a8480e3efa
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46

Comment 6

2 years ago
Mike Hommey (or someone involved in this patch), could you take a look at bug 1268251 ? It seems this issue was caused by your patch (or your patch exposed some another issue here).

Thanks.
You need to log in before you can comment on or make changes to this bug.