vagrant provisioning failure: TypeError: __init__() got an unexpected keyword argument 'allow_unverified'

RESOLVED DUPLICATE of bug 1241251

Status

developer.mozilla.org
General
RESOLVED DUPLICATE of bug 1241251
2 years ago
2 years ago

People

(Reporter: willkg, Unassigned)

Tracking

Details

So there I was. Trying to test the new settings refactor with a fresh vagrant vm when the vagrant provisioning kept failing.

"TypeError: __init__() got an unexpected keyword argument 'allow_unverified'", it kept saying. Over and over and over again. Its words buffeting my face like being hit repeatedly with concrete boxing gloves.

My mind reeled from the pain ... but then a right hook brought me back to where I was and I managed to focus and stare at the output intently looking for the cherry on top of this chocolate failure and vanilla traceback sundae.

My eyes finally alighted on the line that made it all clear:

pip: '8.0.0'

Pip 8 has come. We are all saved.


This bug covers fixing all the things (vagrant, deploys, etc) to either require a <8 version of pip or ditch peep and switch whole hog to pip 8.
Duping this to Jannis' because he did the work already.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1241251
You need to log in before you can comment on or make changes to this bug.