Failed/Busted Builds should not taken into account for eta for builds

RESOLVED DUPLICATE of bug 1228983

Status

Tree Management
Treeherder
RESOLVED DUPLICATE of bug 1228983
2 years ago
2 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
We had a windows build bustage that caused busted/failed builds around ~ 12 minutes after starting.

Now with this fixed bustage new builds have information like for pgo builds:
Windows XP pgo Build (B)  33 mins overdue, typically takes ~ 12 mins 

of course pgo builds never take 12 minutes :) so we maybe want to exclude failed builds into that eta calculation and only use completed/sucess builds

Comment 1

2 years ago
Yeah agree it doesn't take job state into account when it should. Bug 1228983 has this and a few other suggestions :-)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1228983
You need to log in before you can comment on or make changes to this bug.