Closed Bug 1241062 Opened 4 years ago Closed 4 years ago

Abnormal timestamps of vp9cake.webm

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox46 --- fixed

People

(Reporter: jwwang, Unassigned)

Details

timestamps:

D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [0,13500] disc=1
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [-6500,13500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [-6500,13500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [-6500,13500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [-6500,13500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [-6500,13500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [-6500,13500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [-6500,13500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [153500,173500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [153500,173500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [153500,173500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [153500,173500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [153500,173500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [153500,173500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [153500,173500] disc=0
D/MediaSample Decoder=7ff1aeb44b70 OnAudioDecoded [153500,173500] disc=0

We have negative timestamps and several samples with the same timestamps.
Depends on: 1239223
isn't this a dupe of bug 1239223 ?

In any case, the first audio sample of this file *is* negative

interestingly, ffprobe shows that some video samples as having duration of "N/A"
I don't think so. The logs are produced with bug 1239223 fixed.
Oh I see, it's Opus, and we haven't fixed the decoder there (note that the issue has always been there). Similar to bug 1239223 but for Opus instead of Vorbis.
this is not vorbis but opus
No longer depends on: 1239223
Flags: needinfo?(jyavenard)
https://hg.mozilla.org/mozilla-central/rev/21f00c74df22
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.