Unable to upload a new version to the app - loqui

VERIFIED FIXED in 2016-02-02

Status

Marketplace
Developer Pages
P1
major
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: krupa, Assigned: ashort)

Tracking

2016-02-02
x86
All
Points:
---

Details

(URL)

(Reporter)

Description

2 years ago
steps to reproduce:
1. Load https://marketplace.firefox.com/developers/app/loqui/status
2. Upload a new version
3. After validation is successful, click Continue


sentry: https://sentry.prod.mozaws.net/operations/olympia-prod/group/207146/


traceback details:


Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "django/db/transaction.py", line 394, in inner
    return func(*args, **kwargs)
  File "django/db/transaction.py", line 394, in inner
    return func(*args, **kwargs)
  File "newrelic/hooks/framework_django.py", line 499, in wrapper
    return wrapped(*args, **kwargs)
  File "mkt/site/decorators.py", line 101, in wrapper
    return f(*args, **kw)
  File "mkt/webapps/decorators.py", line 43, in wrapper
    return f(request, addon, *args, **kw)
  File "mkt/site/decorators.py", line 31, in wrapper
    return func(request, *args, **kw)
  File "mkt/developers/decorators.py", line 48, in wrapper
    return fun()
  File "mkt/developers/decorators.py", line 27, in fun
    return f(request, addon_id=addon.id, addon=addon, *args, **kw)
  File "mkt/developers/views.py", line 226, in status
    res = run_validator(ver.all_files[0].file_path)
  File "mkt/developers/tasks.py", line 140, in run_validator
    spidermonkey=settings.SPIDERMONKEY)
  File "appvalidator/validate.py", line 73, in validate_packaged_app
    submain.prepare_package(bundle, path, timeout)
  File "appvalidator/submain.py", line 63, in prepare_package
    test_package(err, package, path)
  File "appvalidator/submain.py", line 94, in test_package
    output = test_inner_package(err, package)
  File "appvalidator/submain.py", line 119, in test_inner_package
    test(err, package)
  File "appvalidator/testcases/content.py", line 75, in test_packed_packages
    processed = _process_file(err, package, name, file_data)
  File "appvalidator/testcases/content.py", line 116, in _process_file
    testendpoint_js.test_js_file(err, name, file_data)
  File "appvalidator/testcases/scripting.py", line 35, in test_js_file
    tree = get_tree(data, err, filename, spidermonkey_path)
  File "appvalidator/testcases/javascript/spidermonkey.py", line 21, in get_tree
    return _get_tree(code, shell or SPIDERMONKEY_INSTALLATION)
  File "appvalidator/testcases/javascript/spidermonkey.py", line 102, in _get_tree
    parsed = get_tree_from_spidermonkey(shell, code)
  File "appvalidator/testcases/javascript/spidermonkey.py", line 142, in get_tree_from_spidermonkey
    return json.loads(data, strict=False)
  File "json/__init__.py", line 351, in loads
    return cls(encoding=encoding, **kw).decode(s)
  File "json/decoder.py", line 365, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "json/decoder.py", line 381, in raw_decode
    obj, end = self.scan_once(s, idx)
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1241542
(Reporter)

Comment 2

2 years ago
CORRECTION: sentry link is https://sentry.prod.mozaws.net/operations/zamboni-2/group/207271/
This issue also affects the submission of new versions of Firetext (https://marketplace.firefox.com/app/firetext).
I'd be curious to see if people can reproduce this now. We're eliminating some variables, and we're close to the end of our list.
@David: I can still reproduce this using https://github.com/codexa/firetext/releases/download/v0.5.1/Firetext-0.5.1.zip

Comment 6

2 years ago
Still the same for loqui as well...

Updated

2 years ago
Assignee: nobody → ashort
Priority: -- → P1
Target Milestone: 2016-01-26 → 2016-02-02
I think what's causing this bug is the memory limits Jason added to the processes to work around the original memory issues. Since those issues have been fixed we should be able to revert the config back to what it was before.
This should now be fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
I can confirm that it is fixed!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.