Closed Bug 1241319 Opened 6 years ago Closed 6 years ago

Synced tabs menu panel looks like I'm not logged in when I only have one device connected

Categories

(Firefox :: Sync, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 48
Tracking Status
firefox48 --- fixed

People

(Reporter: ckarlof, Assigned: eoger)

References

Details

Attachments

(5 files, 1 obsolete file)

I realize that it actually says that I need to add a second device, but my gut reaction every time I see this UI is that I'm not logged in on my current device.
Flags: firefox-backlog+
Ryan and Nick, what do you think?
Flags: needinfo?(rfeeley)
Flags: needinfo?(nchapman)
Summary: Synced tabs menu panel looks like I not logged in when I only have one device connected → Synced tabs menu panel looks like I'm not logged in when I only have one device connected
Yeah I agree. I had the same reaction. I think the problem is that the first words in the dialog are "Sign into Firefox". I think we can make the value proposition stronger and call to action clearer.
Flags: needinfo?(nchapman)
A longer term fix will be redoing all the illustrations (so they aren't the same).

In the short term, a copy change can improve things.

In the Downloads panel we say: No downloads for this session.

And in the Add-ons section we say: You don't have any add-ons of this type installed

How is this?

CURRENT:
Sign in to Firefox from your other devices to view their tabs here.

PROPOSED:
No synced tabs because you’ve yet to sign in to Firefox on another device.
Flags: needinfo?(rfeeley)
Flags: needinfo?(nchapman)
Flags: needinfo?(ckarlof)
> PROPOSED:
> No synced tabs because you’ve yet to sign in to Firefox on another device.

I like the direction. "because you've yet to sign in to" is quite a mouthful, though. 

What about trying to use the language of "Add another device"?

e.g., "No synced tabs found. You need to add another device to Firefox Sync to see remote tabs."
Flags: needinfo?(ckarlof)
As a point of reference, Chrome says: "No tabs from other devices".
(In reply to Chris Karlof [:ckarlof] from comment #4)
> > PROPOSED: "because you've yet to sign in to" is quite a mouthful, though. 

It is. I would love to put our copywriter on this, but in the meantime is this better?

No synced tabs – sign in to Firefox on another device to see them listed here.
> No synced tabs – sign in to Firefox on another device to see them listed here.

It's better. It does have the "sign in to Firefox" phrase which was triggering the initial confusion, though.
Hi - Michelle Heubusch here - I'm working with the UX team on content and copy recommendations and Ryan asked that I weigh in, as I am looking at all the copy in the browsers to standardize tone, style, punctuation, etc.  Here's my recommendation:  
No Synced Tabs 
Let’s sync up! View tabs here when you sign in to Firefox on other devices. 

Feel free to email me or find me on IRC with any questions.
> No Synced Tabs 
> Let’s sync up! View tabs here when you sign in to Firefox on other devices. 

Ryan Feeley, is there a cheap way to validate that this copy choice communicates the right message? I'm still a little concerned it contains the phrase "sign in to Firefox" (although it's no longer leading the sentence).
Flags: needinfo?(nchapman)
Priority: P3 → P1
Attached image synced-tabs.png
FTR, here's a first cut with the proposed messaging. IMO it looks less like "please log in" than the previous version (but it does look like "No Synced Tabs" should be bold or something?)

(In reply to Chris Karlof [:ckarlof] from comment #9)
> I'm still a little concerned it contains the
> phrase "sign in to Firefox" (although it's no longer leading the sentence).

Michelle, can you come up with something without the words "sign in"? Maybe something like "Let’s sync up! View tabs here from Firefox on your other devices."? Or maybe something using "connect" or similar?
Flags: needinfo?(mheubusch)
IMO, it looks pretty good as is, despite the "sign in" language still in there.

I'll defer to Michelle, but it might be worth landing it and trying to do some cheap validation around whether there's still a problem or not. I chatted with Michelle over Vidyo about doing this.
Assignee: nobody → markh
Status: NEW → ASSIGNED
Spent much of yesterday on this and some of today getting feedback from my team and non-Mozillians. Stay tuned.
Action is for rfeeley to finish UX design with Michelle's copy recommendation.
Assignee: markh → rfeeley
Flags: needinfo?(mheubusch)
Attached image no-synced-tabs-yet.png
This is what my team came up with. The text colour is too dark (match what we have) but this is what we think works best.
Works for you?
Flags: needinfo?(ckarlof)
Yep!
Flags: needinfo?(ckarlof)
Assignee: rfeeley → nobody
Status: ASSIGNED → NEW
Priority: P1 → P2
Attached patch bug-1241319.patch (obsolete) — Splinter Review
Screenshot to follow
Assignee: nobody → edouard.oger
Status: NEW → ASSIGNED
Attachment #8739496 - Flags: review?(markh)
Simplified patch
Attachment #8739496 - Attachment is obsolete: true
Attachment #8739496 - Flags: review?(markh)
Attachment #8739509 - Flags: review?(markh)
Attachment #8739509 - Flags: review?(markh) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0611a1fb8d39
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Depends on: 1263441
You need to log in before you can comment on or make changes to this bug.