Closed Bug 1241357 Opened 5 years ago Closed 5 years ago

HTTP Links from within certain PDF files generated by Word converter 9.0 do not function.

Categories

(Firefox :: PDF Viewer, defect)

43 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 46
Tracking Status
firefox46 --- fixed

People

(Reporter: bwatt, Unassigned)

References

Details

(Keywords: regression, testcase)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.86 Safari/537.36

Steps to reproduce:

Load a PDF file in Firefox that contains links. If generated by this older software, the links will not do anything. Links appear to contain an extra character at the end of the file name that do not exist in other PDF viewers (Adobe Reader, Chrome, etc...). Occurs on both Linux and Windows. This issue did not exist in older versions of Firefox, and does not occur with files generated by newer versions of the Word converter. As a workaround, I've asked the customer who generated these PDFs to re-generate them in a newer version of the software, since files generated by the newer software work without error. The reporting user has requested that a bug report be filed.


Actual results:

Link should take you to the website/file listed (destination is another PDF file on the remote system)


Expected results:

Link does precisely nothing.
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Ever confirmed: true
Keywords: regression
Ahh, I read the section on testing against nightly builds too late. This appears to have been fixed in Firefox 46. I'll let the user know that a fix is expected some time around May/June, according to the fast track calendar. I apologize for the hasty bug-reporting.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
And sorry for mismarking. Thank you for being patient with me - I'll be more careful next time.
You're doing very good, there is no improper.

Just out of curiosity, I have found its source. Like the "#6834 Strip `null` (\x00) characters from the URLs in LinkAnnotations (issue 6832)".
Depends on: 1237815
Keywords: testcase
Resolution: WORKSFORME → FIXED
Target Milestone: --- → Firefox 46
Worth an Aurora patch for this? 45 is going to be the next ESR release.
Flags: needinfo?(bdahl)
A supplement, this regression appears in 2015-08-05, caused by bug 1189852.
Jonas, do you think this is worth uplifting?
Flags: needinfo?(bdahl) → needinfo?(jonas.jenwald)
(In reply to Brendan Dahl [:bdahl] from comment #7)
> Jonas, do you think this is worth uplifting?

Perhaps, but there has been quite a bit of movement in the annotation code lately, which could make uplifts a bit difficult.

Given that there are also other patches that may be worth uplifting (e.g. fixes related to ShadingPatterns, and of course the Type2 charstring validation patch), could we consider simply uplifting the current moz-central to aurora instead?
Flags: needinfo?(jonas.jenwald) → needinfo?(bdahl)
I haven't heard of many occurrences of this bug, so I don't think it's worth uplifting that change. Let's just let this ride the trains as usual.
Flags: needinfo?(bdahl)
You need to log in before you can comment on or make changes to this bug.