Selecting text after alert() in .blur() jQueries method

RESOLVED DUPLICATE of bug 1043392

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 1043392
2 years ago
2 years ago

People

(Reporter: whiteworkwork, Unassigned)

Tracking

({testcase})

43 Branch
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: e10s disabled)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36

Steps to reproduce:

Here is the fiddle -> https://jsfiddle.net/tbtfbLon/

After alert fires popup box we click on "OK" button and if we start moving our mouse up or down without clicking it starts to selecting text like as if we have been pressing button on a mouse to select text. Looks like I have this behavior only in Firefox.

Tried on Mac and Windows - getting the same behavior.

Mac's Firefox ver. 43.0.4 Window's Firefox ver. 41.0.2


Actual results:

It starts selecting text.


Expected results:

It shouldn't select text.
(Reporter)

Comment 1

2 years ago
Maybe, this one is better https://jsfiddle.net/tbtfbLon/3/
(Reporter)

Comment 2

2 years ago
Created attachment 8710258 [details]
firefox_bug.png

Comment 3

2 years ago
Created attachment 8710320 [details]
1241381.html

Updated

2 years ago
Keywords: testcase
Reproduce the issue on Mac OS 10.11, on 
 - Nightly 46.0a1, Build ID 20160125030203, User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:46.0) Gecko/20100101 Firefox/46.0, e10s disabled. The bug is not reproducible  with e10s enabled.
 - Release 43.0.4, Build id 20160105164030, User agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
Status: UNCONFIRMED → NEW
Component: Untriaged → Event Handling
Ever confirmed: true
OS: Unspecified → Mac OS X
Product: Firefox → Core
Hardware: Unspecified → x86
Whiteboard: e10s disabled

Comment 6

2 years ago
I can repro on Win7 Nightly46.0a1 without e10s
OS: Mac OS X → All

Comment 7

2 years ago
Regression of Bug 933483.
And this seems to duplication of Bug 1043392.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043392
You need to log in before you can comment on or make changes to this bug.