[TB 38.5.0] Inbox file hard limit to 4GB still at work (not a warning)

RESOLVED DUPLICATE of bug 789679

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 789679
2 years ago
2 years ago

People

(Reporter: eatdirt, Unassigned)

Tracking

38 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20151215172838

Steps to reproduce:

After receiving emails using POP in the last ten years, my ./Mail/blablabox/Inbox file reached 4GB.


Actual results:

TB blocked any new message with an *error*, and not a warning, claiming that my Inbox file or folder was full.


Expected results:

Nothing.
Because my file system is XFS and can clearly support more than 4GB file size, I am using a real operating system, namely Linux (mageia) and my home directory was far to be full.
Moreover I am not using any quota and ulimit -f returns unlimited. Finally, I have files greater than 4GB a bit everywhere on that same hard-drive.
I am therefore concluding that this bug, which has been around since the beginning of TB, and maybe Netscape, is still there :)

PS: May be duplicate to #789679, with the difference however that I am getting an error and not a warning, which thereby prevents any further usage of TB to read emails.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

2 years ago
This is a dupe of bug 789679. For everybody the TB message is a hard error and no new messages can be downloaded into Inbox. That is an internal limitation of Thunderbird, regardless of your OS and filesystem (it says folder full, not filesystem/disk full). Of course we are working on it and most of the necessary steps are already done.
You may watch bug 789679 for the progress.

Meanwhile, you really need to move some messages out of Inbox into other folders.

OR you may try to switch your mailstore from mbox to maildir. There are some small glitches with it yet (you may watch bug 1078367), but you can try it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789679
(Reporter)

Comment 2

2 years ago
Thanks for the clarifications, now it is clear for me that it is a hard limit indeed (sorry for the noise). I searched around and found an unbelievable amount of noise around this issue, including wrong tricks to supposedly fix it.

I am just posting here that the easy solution is to archives the old messages. I selected all my emails from 2006 to 2010 and clicked "archives". It took a while for TB to do it, but it worked. The Inbox file was finally reduced in size and I was able to get the new emails. I mention however that the file system did not update the file size immediately (xfs mounted in relatime) and after TB returned to a normal CPU state and no disk write, it was still popping out the error message for a little while to my despair, but ultimately worked.

thanks

Comment 3

2 years ago
You may need to compact the folder after the moving of the messages, so that the space is actually freed and the file is shrinked in the filesystem.
But if you have automatic compact turned on in Options, it may have done it after a while so it now works for you.
You need to log in before you can comment on or make changes to this bug.