[TV][2.5][Web Apps] Press option key to show notification

RESOLVED FIXED

Status

Firefox OS
Gaia::TV
P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mlien, Assigned: rickychien)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed)

Details

(Whiteboard: [ft:conndevices])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8710306 [details]
Screenshot from 2016-01-21 16:28:42.png

[Description]
Add/Delete app/website from Web Apps will show banner with two line strings and have an icon.

[Reproduce Steps]
1. Launch Apps -> Web Apps/Dev Web Apps
2. Navigating to any app/website -> Press option key
3. Press OK key on "Added to Apps"
4. Press option key
5. Press OK key on "Delete from Apps"

[Build Information]
Environment: 2.5 Simulator
Gaia: https://github.com/mozilla-b2g/gaia/commit/184523b202608f24e01cda720370de3ee7c5b8c3
Gecko: https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/be1ec31308366db734d15a04db7c4b4697515b20
Mulet: https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/be1ec31308366db734d15a04db7c4b4697515b20 

[Expected Result]
Both step 3 and step 5 should show one line string banner

[Actual Result]
The banner contains two line strings and an icon
(Reporter)

Comment 1

2 years ago
Created attachment 8710308 [details]
Screenshot from 2016-01-21 16:29:17.png
(Reporter)

Updated

2 years ago
QA Whiteboard: [COM=TV::Web Apps]
(Reporter)

Comment 2

2 years ago
Real TV also have the same problem

Updated

2 years ago
Priority: P1 → P3

Updated

2 years ago
Blocks: 1187806
No longer blocks: 1204762

Comment 3

2 years ago
Luke, I remember you modified banner behavior before. Is this expected?
Flags: needinfo?(lchang)
Hi Ricky,

The title and icon in the system banner was added by you in bug 1235128. Could you confirm if it's correct?
Flags: needinfo?(lchang) → needinfo?(rchien)
See Also: → bug 1235128
(Assignee)

Comment 5

2 years ago
OK, I'll make sure soon.
Assignee: nobody → rchien
Flags: needinfo?(rchien)
(Reporter)

Comment 6

2 years ago
Hi Ricky, I saw you already fixed this issue from bug1239914 and currently it show one line string banner
But as we discussed, the one line string banner shouldn't apply to the reminder banner of using option key to add content to apps.

Could you help to check with this, thanks.

Current revision of simulator we use:
gaia:
https://github.com/mozilla-b2g/gaia/commit/8a0d9deb2cd47df25750ed2c6820909e4feac3bb
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/2b6f8826861a846c3d1d98ef595c8dfbf8b59328
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/2b6f8826861a846c3d1d98ef595c8dfbf8b59328
(Assignee)

Updated

2 years ago
Summary: [TV][2.5][Web Apps] The center-bottom banner should only have one line string → [TV][2.5][Web Apps] System banner shouldn't apply to the option key's reminder banner

Updated

2 years ago
blocking-b2g: --- → 2.5+
Created attachment 8713104 [details] [review]
[gaia] rickychien:preview-hint > mozilla-b2g:master
(Assignee)

Comment 8

2 years ago
Comment on attachment 8713104 [details] [review]
[gaia] rickychien:preview-hint > mozilla-b2g:master

A patch a day keeps the doctor away.
Attachment #8713104 - Flags: review?(lchang)
(Assignee)

Updated

2 years ago
Summary: [TV][2.5][Web Apps] System banner shouldn't apply to the option key's reminder banner → [TV][2.5][Web Apps] Press option key to show notification
(Assignee)

Comment 9

2 years ago
This patch also fix the bug that preventing "Press Options to Add to Apps" notification when user already added website to Apps.
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1241425
Attachment #8713104 - Flags: review?(lchang) → review+
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/ef3d473c534bbb4d66c34481c5c717e1e031a804
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Comment on attachment 8713104 [details] [review]
[gaia] rickychien:preview-hint > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1235128
[User impact] if declined: Incorrect UI of "add to apps" notification
[Testing completed]: manually verified
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]:
preview-app-hint
Attachment #8713104 - Flags: approval-gaia-v2.5?

Comment 13

2 years ago
Comment on attachment 8713104 [details] [review]
[gaia] rickychien:preview-hint > mozilla-b2g:master

Approve for Tv 2.5
Attachment #8713104 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.