[TV 2.5][Browser] Failed to go back to the previous screen after pressing Back button in the option menu (History)

VERIFIED FIXED in 2.6 S6 - 1/29

Status

P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: cynthiatang, Assigned: danhuang)

Tracking

unspecified
2.6 S6 - 1/29
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:
 1. Launch Browser App
 2. Open any webpage 
 3. Select a history and press Option
 4. Press Back

Actual result:
 - Nothing happened

Expected result:
 - Exit the Option Menu
 - Go back to the previous screen

================================================
master + mulet
commit 619766a1ce78d50fb8a3b5a9e0821c335a0ed7ee
Merge: b1b2bf8 e524997
Author: Fischer-L <Fischer-L@users.noreply.github.com>
Date:   Thu Jan 21 12:49:38 2016 +0800


================================================
fxos-simulator-2.5.20160121031516._tv-linux64.xpi

gaia:
https://github.com/mozilla-b2g/gaia/commit/184523b202608f24e01cda720370de3ee7c5b8c3

gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ea1b75e4b851d242182ef0c8a1ade5eb38b2c00f

mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ea1b75e4b851d242182ef0c8a1ade5eb38b2c00f
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=TV Browser]
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
(Reporter)

Updated

3 years ago
Blocks: 1239346
(Reporter)

Updated

3 years ago
Flags: needinfo?(yliao)
Assignee: nobody → dhuang
Flags: needinfo?(yliao) → needinfo?(dhuang)
Created attachment 8712604 [details] [review]
[gaia] danhuang1202:1241458_backspace_key_support_in_smartList_option > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Flags: needinfo?(dhuang)
Attachment #8712604 - Flags: review?(yliao)

Updated

3 years ago
blocking-b2g: --- → 2.5+
Attachment #8712604 - Flags: review?(yliao) → review+
(Assignee)

Updated

3 years ago
Target Milestone: --- → 2.6 S6 - 1/29
(Assignee)

Comment 2

3 years ago
Merge in master:
https://github.com/mozilla-b2g/gaia/commit/d24ca5db1b3f51216534f57629f6bee9486bf4b4
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

3 years ago
Comment on attachment 8712604 [details] [review]
[gaia] danhuang1202:1241458_backspace_key_support_in_smartList_option > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Bug 1239346
[User impact] if declined: The option in bookmark/history list can't be closed
[Testing completed]:https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=d24ca5db1b3f51216534f57629f6bee9486bf4b4&selectedJob=3469254
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8712604 - Flags: approval-gaia-v2.5?
Comment on attachment 8712604 [details] [review]
[gaia] danhuang1202:1241458_backspace_key_support_in_smartList_option > mozilla-b2g:master

Approve for TV 2.5
Attachment #8712604 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.