Closed Bug 1241476 Opened 4 years ago Closed 4 years ago

Update in-tree libcubeb

Categories

(Core :: Audio/Video: cubeb, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox46 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

Details

Update our in-tree libcubeb to bring in the full-duplex changes and some device-enumeration updates.
I had to back this (and everything else from this push) out for causing various crashes on WinXP. They all seem to mention "winmm_stream_init" or "cubeb_winmm.c".

https://treeherder.mozilla.org/logviewer.html#?job_id=20232505&repo=mozilla-inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/739da31ca2e2
A write to 0x0 is usually libcubeb's XASSERT firing.  There should be a message printed to stderr, but I can't find it in the log.

Anyway, looking at the very few changes made to cubeb_winmm.c since the last landing, the problem is pretty obvious:

  XASSERT(input_stream_params && "not supported.");

should be:

  XASSERT(!input_stream_params && "not supported.");

...like it is in all of the other backends.

Pushed a fix upstream here: https://github.com/kinetiknz/cubeb/commit/2de1ab50e16763fd88ec1b5bae30422de598eed0
https://hg.mozilla.org/mozilla-central/rev/c4db43c72f53
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Depends on: 1242152
You need to log in before you can comment on or make changes to this bug.