[DevTools][Memory] heap-tree-number and heap-tree-percent will overflow when filter word is set (e.g. "objects")

RESOLVED DUPLICATE of bug 1226878

Status

RESOLVED DUPLICATE of bug 1226878
3 years ago
4 months ago

People

(Reporter: magicp.jp, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk

Firefox Tracking Flags

(firefox45 affected, firefox46 affected)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160121030208

Steps to reproduce:

1. Start Nightly
2. Open Memory Tool
3. Run "Take Snapshot"
4. Set filter word (e.g. "objects")


Actual results:

heap-tree-number and heap-tree-percent will overflow when filter word is set (e.g. "objects")
heap-tree-percent is over 100%. Is this correct?


Expected results:

It should not be overflowed. If calculation is wrong, should work correctly.
(Reporter)

Updated

3 years ago
Blocks: 1221506
Has STR: --- → yes
status-firefox45: --- → affected
status-firefox46: --- → affected
Component: Untriaged → Developer Tools: Memory
OS: Unspecified → All
Hardware: Unspecified → All
We are tracking this in bug 1226878 -- thanks for filing!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226878

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.