Closed Bug 12416 Opened 21 years ago Closed 21 years ago

Crash double-clicking on empty space

Categories

(Core :: DOM: Editor, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED DUPLICATE of bug 11857

People

(Reporter: sfraser_bugs, Assigned: buster)

Details

I can reliably crash the editor with the following steps:

1. Select some text in the first line of the test page (from 'add' to 'testing')
2. Double-click on the empty space above that first line.

Stack is:

  00000000    PPC  1FB43B60
  0C01BA40    PPC  1FB42F54  main+00060
  0C01B9F0    PPC  1FB427A4  main1(int, char**)+00E98
  0C01B850    PPC  1E07F7D0  nsAppShellService::Run()+00020
  0C01B810    PPC  1E057B7C  nsAppShell::Run()+00050
  0C01B790    PPC  1E058920  nsMacMessagePump::DoMessagePump()+00044
  0C01B740    PPC  1E058B24  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00084
  0C01B6F0    PPC  1E058E18  nsMacMessagePump::DoMouseDown(EventRecord&)+000C0
  0C01B600    PPC  1E05994C
nsMacMessagePump::DispatchOSEventToRaptor(EventRecord&, GrafPort*)+0004C
  0C01B5B0    PPC  1E052EF8  nsMacMessageSink::DispatchOSEvent(EventRecord&,
GrafPort*)+00048
  0C01B570    PPC  1E04C4B4  nsMacWindow::HandleOSEvent(EventRecord&)+0004C
  0C01B510    PPC  1E04CC34  nsMacEventHandler::HandleOSEvent(EventRecord&)+000B0
  0C01B4C0    PPC  1E04E680  nsMacEventHandler::HandleMouseDownEvent(EventRecord&
)+00228
  0C01B400    PPC  1E037770  nsWindow::DispatchMouseEvent(nsMouseEvent&)+00060
  0C01B3A0    PPC  1E0376B0  nsWindow::DispatchWindowEvent(nsGUIEvent&)+00028
  0C01B360    PPC  1E0375BC  nsWindow::DispatchEvent(nsGUIEvent*, nsEventStatus&
)+000A8
  0C01B310    PPC  1CBA9444  HandleEvent(nsGUIEvent*)+00064
  0C01B2C0    PPC  1CBA6130  nsViewManager::DispatchEvent(nsGUIEvent*,
nsEventStatus&)+007A8
  0C01B100    PPC  1CBAB384  nsView::HandleEvent(nsGUIEvent*, unsigned int,
nsEventStatus&, int&)+00160
  0C01B080    PPC  1CBAB384  nsView::HandleEvent(nsGUIEvent*, unsigned int,
nsEventStatus&, int&)+00160
  0C01B000    PPC  1CBAB384  nsView::HandleEvent(nsGUIEvent*, unsigned int,
nsEventStatus&, int&)+00160
  0C01AF80    PPC  1CBAB414  nsView::HandleEvent(nsGUIEvent*, unsigned int,
nsEventStatus&, int&)+001F0
  0C01AF00    PPC  1CCFB5C4  PresShell::HandleEvent(nsIView*, nsGUIEvent*,
nsEventStatus&)+00460
  0C01AE60    PPC  1CE13640  nsHTMLHeadingElement::HandleDOMEvent(nsIPresContext&
, nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus&)+00040
  0C01AE20    PPC  1CF30410  nsGenericElement::HandleDOMEvent(nsIPresContext&,
nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus&)+00154
  0C01ADC0    PPC  1CDDD85C  nsHTMLBodyElement::HandleDOMEvent(nsIPresContext&,
nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus&)+00040
  0C01AD80    PPC  1CF30410  nsGenericElement::HandleDOMEvent(nsIPresContext&,
nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus&)+00154
  0C01AD20    PPC  1CE1BC94  nsHTMLHtmlElement::HandleDOMEvent(nsIPresContext&,
nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus&)+00058
  0C01ACE0    PPC  1CCE3658  nsDocument::HandleDOMEvent(nsIPresContext&, nsEvent*
, nsIDOMEvent**, unsigned int, nsEventStatus&)+00100
  0C01AC70    PPC  1CDA41F8  nsEventListenerManager::HandleEvent(nsIPresContext&,
nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus&)+0022C
  0C01AB40    PPC  1DF8C5A0
nsTextEditorMouseListener::MouseDblClick(nsIDOMEvent*)+000D8
sujay, could you please test to see if this is XP, or just mac?
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
this turns out to be the GetSelectedElement crash.


*** This bug has been marked as a duplicate of 11857 ***
yes this is XP...I just reproduce it on Windows...
Status: RESOLVED → VERIFIED
verified in 8/24 build.
You need to log in before you can comment on or make changes to this bug.