Closed Bug 1241605 Opened 6 years ago Closed 6 years ago

Stretching the Homescreen to the side then swiping down will cause it to remain stretched

Categories

(Core :: Panning and Zooming, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1240202
Tracking Status
b2g-v2.5 --- affected
b2g-master --- affected

People

(Reporter: JMercado, Unassigned)

References

()

Details

(Whiteboard: [2.6-Daily-Testing][spark])

Attachments

(1 file)

Attached file Stretching Logcat.txt
Description:
If the user stretches the homescreen to the side and then swipes down with another finger, the homescreen will remain stretched out.  This only occurs after reaching the homescreen for the first time since a flash or restart.
Note: This is a followup to bug 1231228 which fixes this issue occurring whenever attempted.


Repro Steps:
1) Update a Aries to 20160121105100
2) Restart the DUT
3) Upon reaching the homescreen immediately swipe right to scretch the screen and hold
4) While holding swipe down as well


Actual:
Homescreen remains stretched


Expected:
Homescreen does returns to its non stretched state.

Environmental Variables:
Device: Aries 2.6
Build ID: 20160121105100
Gaia: 619766a1ce78d50fb8a3b5a9e0821c335a0ed7ee
Gecko: 977d78a8dd78afbc0153d37fd9887c3a200dce6a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0


Repro frequency: 10/10
See attached: logcat and video
This issue also occurs on 2.6 Flame.

Actual Results: The homescreen remains stretched

Environmental Variables:
Device: Flame 2.6
BuildID: 20160121030252
Gaia: 619766a1ce78d50fb8a3b5a9e0821c335a0ed7ee
Gecko: 977d78a8dd78afbc0153d37fd9887c3a200dce6a
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0


Note: The original issue (bug 1231228) was never fixed on 2.5 so this issue does occur as part of the larger original issue.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(bugmail.mozilla)
Is this a dupe of bug 1231228? It's not clear to me what the difference is.
Flags: needinfo?(bugmail.mozilla)
This bug was written up per your comment here https://bugzilla.mozilla.org/show_bug.cgi?id=1231228#c24.  The difference is that this issue ONLY reproduces right after reaching the homescreen whereas that issue happened at any time.
Oh, sorry, my mistake. I meant "Is this a dupe of bug 1240202?" Both of these seem like they were written up based on that comment you linked to.
ni for comment 4. (I suspect the answer is "yes, this is the same as bug 1240202").
Flags: needinfo?(jmercado)
That is definitely correct.  Sorry for the dupe.
Status: NEW → RESOLVED
Closed: 6 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(jmercado)
Resolution: --- → DUPLICATE
Duplicate of bug: 1240202
You need to log in before you can comment on or make changes to this bug.