Menu disappears in Mozillians.org Profile Settings with narrow viewport

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Mozinet, Assigned: tasos)

Tracking

2016-2.1

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8710640 [details]
Mozillians.org Profile Settings Page (fr)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

My Firefox is about 900px large and the new Mozillians.org Profile Settings menu isn't displayed somewhere in the page.
Thanks for reporting that, it looks like an issue with our mobile view rendering.

@nikos
Can you take a look at this?
Flags: needinfo?(nikos)
Yes, this is by design. Our current container for the site is 940px (which is pretty standard for web design). Anything smaller than this is rendered as single column UI.
Flags: needinfo?(nikos)
(Reporter)

Comment 3

2 years ago
Single column OK, but here there is no menu.
Oh you mean the top menu with all the options? That's on the top left corner next to the mozillians logo. The 3 bars icon.
(Reporter)

Comment 5

2 years ago
Created attachment 8713224 [details]
Mozillians Profile Edition Settings menu (fr)

Nikos talks about the general Mozillians menu (hamberger). I mean the settings menu. This menu is present on large pages, not on narrow pages.
Yes, that's not displayed on resolution lower that 940px. You should see all settings in single column. You should also see a button at the bottom revealing all Settings, so there is no need for the menu.
(Reporter)

Comment 7

2 years ago
So the bug is there. The "Show all settings" link displays anything. I tried the user profile edition (in French) with 2 Firefox 44 profiles and in Nightly. Clicking the "Show all settings" link just hide the link.
Created attachment 8713240 [details]
show-settings.png

So, just to make clear. You see the "Show all Settings" button, but it does nothing when you press it.
(Reporter)

Comment 9

2 years ago
Yes. It's this link (even in French version). When I click the link, it just disappears. No additional content appears. I tested with a 44 without extensions profile and a beta profile, the behavior is the same.
I can't reproduce it on FF44. Can you open the Web Console (Shift + Ctrl + K) and enable at least the JS, Security, Logging tabs and see if you are getting any error message?
(Reporter)

Comment 11

2 years ago
At page loading in Firefox 44 and Nightly 47:

    Content Security Policy: Les paramètres de la page ont empêché le chargement d'une ressource à https://login.persona.org/communication_iframe (« default-src https://mozillians.org http://*.mapbox.com https://*.mapbox.com »). <inconnu>
(Assignee)

Updated

2 years ago
Assignee: nobody → tasos
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 13

2 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/ea12b87835febc1ee9e6754461e546e7d0a8891a
[fix bug 1241606] Expand settings menu in mobile view.

https://github.com/mozilla/mozillians/commit/0f6e8e02185a16abcce6f5416b85136dc1c088b3
Merge pull request #1319 from akatsoulas/fix-ui-issue

[fix bug 1241606] Expand settings menu in mobile view.

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Verified on stage:

* Login and trigger "Responsice Design View" from Developer Tools
* Adjust to 360x640
* Navigate to Settings
* Scroll down to "Show all Settings" and press the button
* Button is hidden and all settings options are displayed
Status: RESOLVED → VERIFIED
Version: next → 2016-2.1
You need to log in before you can comment on or make changes to this bug.