Doesn't properly highlight JavaScript template strings.

RESOLVED FIXED

Status

Webtools
DXR
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mythmon, Assigned: Tom Klein)

Tracking

Trunk

Firefox Tracking Flags

(firefox46 affected)

Details

(Reporter)

Description

3 years ago
DXR doesn't see ` as a quote character in JS, producing some silly looking highlighted code:

https://dxr.mozilla.org/mozilla-central/rev/66e07ef46853709e3fa91e7c9ad9fe6abf0d5f06/dom/manifest/ValueExtractor.jsm#35
(Assignee)

Comment 1

3 years ago
Though I haven't tested it, I presume that's fixed in pygments by
https://bitbucket.org/birkenfeld/pygments-main/issues/1100/add-support-for-ecmascript-6

Might we want to patch that into the version of pygments used by dxr?
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1246678

Comment 3

2 years ago
Commit pushed to master at https://github.com/mozilla/dxr

https://github.com/mozilla/dxr/commit/dc4d4541b3e5ae3a25a636b4d4a5eab58a858bfe
Upgrade Pygments.  Fixes bug 1241636.

Version 2.1.3 contains both Erik's fix for a slowdown which had caused us to
switch to a patched version of Pygments:
https://bitbucket.org/birkenfeld/pygments-main/commits/8e3e7dd549e5
and Javascript ES6 support to fix bug 1241636:
https://bitbucket.org/birkenfeld/pygments-main/commits/3ecc5b1c8c30

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Assignee: nobody → twointofive
You need to log in before you can comment on or make changes to this bug.