Closed Bug 1241678 Opened 4 years ago Closed 4 years ago

crash in mozilla::layers::CompositorParent::SetConfirmedTargetAPZC

Categories

(Core :: Panning and Zooming, defect, critical)

46 Branch
Unspecified
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox46 --- fixed

People

(Reporter: kats, Assigned: kats)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-d7e9b270-d191-4d35-8ff8-446462160121.
=============================================================

Found this low-volume crash poking around in crash-stats. Looks like state->mParent can be null at http://hg.mozilla.org/mozilla-central/annotate/2e50b83954e6/gfx/layers/ipc/CompositorParent.cpp#l2359
Attached patch PatchSplinter Review
I can't repro the crash so this is mostly untested.
Attachment #8711081 - Flags: review?(bgirard)
Comment on attachment 8711081 [details] [diff] [review]
Patch

Review of attachment 8711081 [details] [diff] [review]:
-----------------------------------------------------------------

Reluctant R+. This has the possibly of turning a crash (obvious) into a correctness issue (subtle, hard to measure the impact and track down). This patch is the practical thing to do but it's probably just wallpapering over why this is null.
Attachment #8711081 - Flags: review?(bgirard) → review+
(In reply to Benoit Girard (:BenWa) from comment #2)
> Reluctant R+. This has the possibly of turning a crash (obvious) into a
> correctness issue (subtle, hard to measure the impact and track down). This
> patch is the practical thing to do but it's probably just wallpapering over
> why this is null.

I agree in theory. However looking at the code it seems like mParent only gets set to null during the shutdown process (during the RecvWillStop handling). And that means things are being torn down so losing this message shouldn't cause any correctness problem.
Yea, I r+ because I think this patch is a practical fix given your analysis. Please land it :)
https://hg.mozilla.org/mozilla-central/rev/333b31c1040c
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.