Closed Bug 1241729 Opened 4 years ago Closed 4 years ago

BMP will trigger 100% CPU usage

Categories

(Core :: ImageLib, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1241728
Tracking Status
firefox46 --- affected

People

(Reporter: tsmith, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, csectype-dos, testcase)

Attachments

(1 file)

435 bytes, application/x-zip-compressed
Details
Attached file test_case.zip
Loading this BMP and then refreshing a few times will trigger 100% CPU usage and the only way to stop it seems to be to close the browser.
This looks like a dup of bug 1241728. It is spending a loooong time (though it will complete eventually) trying to resize/convolve a 3616 x 637534240 image. But the filter chosen in this case doesn't trigger the OOM. However, even without the OOM, it's still spinning. So perhaps your proposed decoder size limits will take care of this one too?
Flags: needinfo?(n.nethercote)
Yes, the size limits should fix this. tnikkel has a patch limiting each dimensions to 1<<20.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(n.nethercote)
Resolution: --- → DUPLICATE
Duplicate of bug: 1241728
Blocks: grizzly
You need to log in before you can comment on or make changes to this bug.