[TV][2.6] Can't leave the bookmark name input field

VERIFIED FIXED

Status

Firefox OS
Gaia::TV::Browser
P1
major
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: oscartsai@allion.com, Assigned: yifan)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [ft:conndevices], URL)

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
[Description]
[TV][2.6] There is no reflection when pressing "OK" button after rename bookmark.

[Testing Steps]
1. Launch Browser
2. Go to CNN website
3. Move cursor to the Star icon
4. Press OK
5. Press Up twice > Press Right > Press OK
6. Press Left > Press OK > Rename

[Expected result]
The bookmark should be renamed properly.

[Actual result]
There is no reflection when pressing "OK" button with keyboard after rename bookmark, but it can work properly when clicking "OK" button with mouse cursor.

[Build Information]
Environment: 2.6 Simulator
gaia:https://github.com/mozillab2g/gaia/commit/3e82ef0565f3a5d69fc98222267f84f0e7a470c4
gecko:https://hg.mozilla.org/mozilla-central/rev/b67316254602a63bf4e568198a5c7d3288a9db27

[TCID]
16621

Updated

2 years ago
Whiteboard: [ft:conndevices]

Updated

2 years ago
QA Whiteboard: [COM=TV Browser]

Comment 1

2 years ago
Update [Build Information].
Environment: 2.6 Simulator
gaia:https://github.com/mozilla-b2g/gaia/commit/385ec34c8fe447342e81a40b4e1cc9a80f37fc33
gecko:https://hg.mozilla.org/mozilla-central/rev/c2256ee8ae9a8ee0bf7ab49a8b1924720d846cc7

Comment 2

2 years ago
This is basic function broken
Severity: minor → major
blocking-b2g: --- → 2.6?
status-b2g-master: --- → affected
Priority: -- → P2

Updated

2 years ago
status-b2g-v2.5: --- → affected
Priority: P2 → P1

Updated

2 years ago
blocking-b2g: 2.6? → 2.5?

Comment 3

2 years ago
Hi yifan, could you help to check it, thanks.
Flags: needinfo?(yliao)
Assign to yifan but I have no idea what 'no reflection' means. Mike, could you clarify? Thanks.
Assignee: nobody → yliao
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(mlien)

Comment 5

2 years ago
(In reply to Evelyn Hung [:evelyn] from comment #4)
> Assign to yifan but I have no idea what 'no reflection' means. Mike, could
> you clarify? Thanks.

That means OK key isn't workable to complete and exit edit mode.
Flags: needinfo?(mlien)
(Assignee)

Comment 6

2 years ago
Couldn't reproduce it on either gaia master or v2.5. But I filed bug 1245769 which is related to this one.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(yliao)
Resolution: --- → WORKSFORME

Comment 7

2 years ago
I can always reproduce this issue with the latest build: https://drive.google.com/folderview?id=0B9Zi9TqbRWsdbUZMUkpRM08xRHc&usp=sharing
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

2 years ago
Hi Yifan,
Can you check again? Thanks.
Flags: needinfo?(yliao)
(Assignee)

Updated

2 years ago
Flags: needinfo?(yliao)
Summary: [TV][2.6] There is no reflection when pressing "OK" button after rename bookmark. → [TV][2.6] Can't leave the bookmark name input field
Created attachment 8721838 [details] [review]
[gaia] begeeben:1241775_cant_leave_the_bookmark > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8721838 - Flags: review?(dhuang)
(Assignee)

Updated

2 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 10

2 years ago
With the patch, when a user press RETURN or ESCAPE key, the keyboard will be closed.
Comment on attachment 8721838 [details] [review]
[gaia] begeeben:1241775_cant_leave_the_bookmark > mozilla-b2g:master

Thanks for the effort!
Attachment #8721838 - Flags: review?(dhuang) → review+
(Assignee)

Comment 12

2 years ago
https://github.com/mozilla-b2g/gaia/commit/820842314034f444b99a350c7ef73727035feeda
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

2 years ago
Comment on attachment 8721838 [details] [review]
[gaia] begeeben:1241775_cant_leave_the_bookmark > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: User will be stocked in the bookmark edit input field
[Testing completed]: manual test thoroughly
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8721838 - Flags: approval-gaia-v2.5?

Comment 14

2 years ago
Comment on attachment 8721838 [details] [review]
[gaia] begeeben:1241775_cant_leave_the_bookmark > mozilla-b2g:master

Approve for TV 2.5
Attachment #8721838 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Hey :yifan, this commit is breaking tv_apps/smart-system/test/marionette/pin_to_home_test.js integration test.

It seems that when you enter a URL in the url bar, and then press enter, it doesnt load the URL. Is that expected? 

Thanks!
Flags: needinfo?(yliao)
(Assignee)

Comment 16

2 years ago
Thank you Alberto! Really sorry to miss it.
Flags: needinfo?(yliao)
Created attachment 8725085 [details] [review]
[gaia] begeeben:revert_1241775 > mozilla-b2g:master
(Assignee)

Comment 18

2 years ago
https://github.com/mozilla-b2g/gaia/commit/9fe5bb2224500e0bc2673747bb1e655498217d0d
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 8725090 [details] [review]
[gaia] begeeben:1241775_cant_leave > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8725090 - Flags: review?(dhuang)
https://github.com/mozilla-b2g/gaia/commit/8766deba2ccda6d2651620e7afc3bf4e5daa9ba4
status-b2g-v2.5: affected → fixed

Updated

2 years ago
Attachment #8725090 - Flags: review?(dhuang) → review+
(Assignee)

Comment 21

2 years ago
https://github.com/mozilla-b2g/gaia/commit/bae79910eb2f3b1a657a40fcd5def0a898214d17
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 22

2 years ago
Comment on attachment 8725090 [details] [review]
[gaia] begeeben:1241775_cant_leave > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Can't edit bookmark title
[Testing completed]: manual test thoroughly
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8725090 - Flags: approval-gaia-v2.5?

Comment 23

2 years ago
This issue is fixed on both v2.6 and v2.5

[Build Info]
2.6 TV Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/bae79910eb2f3b1a657a40fcd5def0a898214d17
gecko:
https://hg.mozilla.org/mozilla-central/rev/bdde3fedb45be528f985a0aff373b37b010fb927

2.5 TV Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/71952d4b5417796380ddab274c5566a8eced2f8b
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/0b279b0579ae5656e3df34d522af06800e0a03bf
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3

Updated

2 years ago
Status: RESOLVED → VERIFIED

Updated

2 years ago
status-b2g-v2.5: fixed → verified
status-b2g-master: affected → verified

Comment 24

2 years ago
Comment on attachment 8725090 [details] [review]
[gaia] begeeben:1241775_cant_leave > mozilla-b2g:master

Approve for TV 2.5
Attachment #8725090 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Created attachment 8727237 [details] [review]
[gaia] begeeben:approval/1241775 > mozilla-b2g:v2.5
Hi Cindy,
Could you please verify this bug in v2.5 again? The patch was landed on March 6th. But you verified it on March 2nd. Thank you.
Flags: needinfo?(cindylee)

Comment 27

2 years ago
(In reply to Cynthia Tang [:cynthiatang] from comment #26)
> Hi Cindy,
> Could you please verify this bug in v2.5 again? The patch was landed on
> March 6th. But you verified it on March 2nd. Thank you.

Hi Cynthia,

I found this issue had been fixed on March 2nd build even though the patch isn't landed yet.
This issue is NOT observed on latest build.
[Build Info]
gaia:
https://github.com/mozilla-b2g/gaia/commit/2ef35d50b1832718760b25ba3b443725fac6e14e
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/43f12254fa79238bc243b57d0d607339fbdc5949
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3
Flags: needinfo?(cindylee)
You need to log in before you can comment on or make changes to this bug.