Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: ho7seduction, Unassigned)

Tracking

43 Branch
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

18.00 KB, text/plain
Details
(Reporter)

Description

3 years ago
Created attachment 8710937 [details]
bug.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

log in to my account to sync my tabs


Actual results:

No sync result. None of my bookmarks appear


Expected results:

To view all my bookmarks

Updated

3 years ago
Component: Untriaged → Sync
Hi David, thanks for the report.  If you enter "about:sync-log" in the address bar, does it show any error logs that might help us tell what's going wrong here?
Flags: needinfo?(ho7seduction)
Whoops, just saw that you already attached one...
Flags: needinfo?(ho7seduction)
Looks like there was a transient server-side error during the sync, which probably didn't help:

"""
1453226071626	Sync.Collection	DEBUG	mesg: DELETE fail 503 https://sync-240-us-west-2.sync.services.mozilla.com/1.5/27186400/storage/passwords?ids={e4a7a244-b995-412d-878f-9d45ffb5c697}
1453226071626	Sync.Collection	DEBUG	DELETE fail 503 https://sync-240-us-west-2.sync.services.mozilla.com/1.5/27186400/storage/passwords?ids={e4a7a244-b995-412d-878f-9d45ffb5c697}
1453226071627	Sync.Engine.Passwords	DEBUG	Delete result: <html>
<head><title>503 Service Unavailable</title></head>
<body bgcolor="white">
<center><h1>503 Service Cloudy: Try again later. </h1></center>
</body>
</html>
"""

But it looks like it only hit while syncing passwords, not bookmarks.

Can you please say a little more about the circumstances here?  Was this trying to set up your first firefox install, or sync with an existing firefox install?  Did you already have a Firefox Account?  Did you need to e.g, reset your password when connecting this device?
Flags: needinfo?(ho7seduction)
(Reporter)

Comment 4

3 years ago

Hello, Ryan, 
I already have Firefox Account. My account is sync with my Desktop PC. The problem occur couple of weeks ago. I didn't try resetting my password, because if the password wasn't correct I'm not going to  be able event to log in with my account in firefox. 
Was that info helpful ?




(In reply to Ryan Kelly [:rfkelly] from comment #3)
> Looks like there was a transient server-side error during the sync, which
> probably didn't help:
> 
> """
> 1453226071626	Sync.Collection	DEBUG	mesg: DELETE fail 503
> https://sync-240-us-west-2.sync.services.mozilla.com/1.5/27186400/storage/
> passwords?ids={e4a7a244-b995-412d-878f-9d45ffb5c697}
> 1453226071626	Sync.Collection	DEBUG	DELETE fail 503
> https://sync-240-us-west-2.sync.services.mozilla.com/1.5/27186400/storage/
> passwords?ids={e4a7a244-b995-412d-878f-9d45ffb5c697}
> 1453226071627	Sync.Engine.Passwords	DEBUG	Delete result: <html>
> <head><title>503 Service Unavailable</title></head>
> <body bgcolor="white">
> <center><h1>503 Service Cloudy: Try again later. </h1></center>
> </body>
> </html>
> """
> 
> But it looks like it only hit while syncing passwords, not bookmarks.
> 
> Can you please say a little more about the circumstances here?  Was this
> trying to set up your first firefox install, or sync with an existing
> firefox install?  Did you already have a Firefox Account?  Did you need to
> e.g, reset your password when connecting this device?
Flags: needinfo?(ho7seduction)
Thanks David, that is indeed helpful in eliminating some possibilities.  To summarize, is the current situation right now that you have a single desktop PC that's connected to your sync account, but it has failed to sync down some bookmarks that you were expecting to be there?
There are a number of weird things in this log - eg:

> 1453226071969	Sync.Engine.Bookmarks	INFO	Uploading all of 30 records
> 1453226080209	Sync.Collection	DEBUG	POST success 200 https://sync-240-us-west-2.sync.services.mozilla.com/1.5/27186400/storage/bookmarks
> 1453226080210	Sync.Engine.Bookmarks	DEBUG	Records that will be uploaded again because the server couldn't store them: mUV5L1AbHj9L, P9oKZnY1HitX, fJHamsa9iff_, bVEXZ-_puu6p, SJb42K4GVoOs, 5fCZtidj2urF, mXgwnybdn4f0, pBDdIh2pRzGM, BOBCMav8X3mD, 794nAjQIgN22, muuz-GkO7UeW, jLdAoYfA7Lp4, menu, 7gPDoGwvAu2b, djez9SgmK8wx, T2jXwIdOO1r8, m5G810oQbZ3a, we93CEg4lcZN, unfiled, b45CFUlZ1RmP, toolbar, iKvlTf2vxnYN, places, CQnMbVtwjeiw, ZdWUI42Q87d9, N4pHgXoqxWbs, 9mLp_2IADlLE, lzdfs7XtwT_p, umKvj9gBgVA8, T1gybBVzvL_5
> ...
> 1453226088539	Sync.Engine.Forms	INFO	Uploading all of 8 records
> ...
> 1453226096772	Sync.Collection	DEBUG	mesg: POST success 200 https://sync-240-us-west-2.sync.services.mozilla.com/1.5/27186400/storage/forms
> 1453226096772	Sync.Collection	DEBUG	POST success 200 https://sync-240-us-west-2.sync.services.mozilla.com/1.5/27186400/storage/forms
> 1453226096774	Sync.Engine.Forms	DEBUG	Records that will be uploaded again because the server couldn't store them: hFMsZ4d5SnmJCPVD, etChZS9vTGa9VoLk, 5oQLoVpWTYKMFety, EJbk68tPQqmefx/U, 849Z9tUsRS6GJDc/, 855yJww/RrSPN1MO, fD8BW1DtQ2i/XFqg, qND6Y2/+RbuQ8dOl

(and *every* collection seems to have this problem)

So we saw a 200 posting but every record was rejected by the server. Richard, have you ever seen anything like this before?

Also, best I can tell from the logs, there are no incoming records - these are all errors posting local records. However, I can't tell from the logs how many devices are attached to the account - we should consider explicitly logging this info.
Flags: needinfo?(rnewman)
> So we saw a 200 posting but every record was rejected by the server.
> Richard, have you ever seen anything like this before?

Ugh, yes, I remember this.  It can happen when there's operational problems on the server, and rather than a 503, the response comes back as a 200 with individual error messages for each BSO you attempted to post.

I think we once tried to make that a 503, but it caused bad client behaviour of some sort.
(In reply to Ryan Kelly [:rfkelly] from comment #7)
> Ugh, yes, I remember this.  It can happen when there's operational problems
> on the server, and rather than a 503, the response comes back as a 200 with
> individual error messages for each BSO you attempted to post.

Oh, OK, thanks - clearing ni? on Richard as it looks like that's all just "service cloudy"
Flags: needinfo?(rnewman)
The reason for the repetition: those records failed to upload, and Sync is saving them to try again later. The retry fails, too. This will continue until either the server stops rejecting them!

If you need more HTTP logging, the reporter can also set

  services.sync.log.logger.network.resources

to "Trace" (with a capital 'T'), relaunch Firefox, and try a sync again to get an error log with full HTTP response bodies.
(Reporter)

Comment 10

3 years ago
(In reply to Ryan Kelly [:rfkelly] from comment #5)
> Thanks David, that is indeed helpful in eliminating some possibilities.  To
> summarize, is the current situation right now that you have a single desktop
> PC that's connected to your sync account, but it has failed to sync down
> some bookmarks that you were expecting to be there?


Hello Ryan,

in summary I have Desktop PC and Laptop. But the sync isn't working on both computers. I think that the problem is with the mozilla servers. I decide to create a new account and everything works just fine for the moment. Yes I lost my bookmark on the previous account but I will find a way to restore some of them.
Ryan and Mark, I feel like there's something actionable to extract from this bug. Can one or both of you please do that (and prioritize it and add it to our backlog)?
Flags: needinfo?(rfkelly)
Flags: needinfo?(markh)
Flags: firefox-backlog+
> It can happen when there's operational problems on the server, and rather than a 503,
> the response comes back as a 200 with individual error messages for each BSO you attempted to post.
> I think we once tried to make that a 503, but it caused bad client behaviour of some sort.

For reference, this was Bug 1062120, which depends on the "cope better with 409s" work that's already on the roadmap.
Flags: needinfo?(rfkelly)
As far as we can tell from the logs, the problem here was the server rejecting all upload attempts with a 503.  I don't have a good explanation for that, apart from possibly the user finding themselves on a slowly-dying node or perhaps some corrupted items in the db.  

> I decide to create a new account and everything works just fine for the moment.

This would have triggered migration to a different node, and assuming that node was healthy, got things working again.

I've bumped the bugs about improving our logging and general response behaviour when POSTs are rejected with a 503, but I don't see other concrete actions to extract from this bug.
Closing WFM because Sync is working again for the reporting and we relevant bugs on file the symptoms encountered for the user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(markh)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.