about:neterror always runs SSL reporting code

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
STR:

0. set keyword.enabled pref to false
1. open a new tab and try to load "::2600"
2. check the error console


ER:
no errors

AR:

something something failedChannel is null

Pointing to:

https://dxr.mozilla.org/mozilla-central/rev/c5da92c5b4906369dee83629f81d647226ac1038/browser/base/content/content.js#459

because when error reporting is automatic, apparently we always run this.

I'm not sure if this means we're always submitting or something, but it warrants investigating, and we should at least bail out at the start of that method if there is no failedChannel. But we should probably also ensure we're not trying to phone home about e.g. non-existent domains or any of the other myriad things we use about:neterror for...

Panos, can you investigate this?
Flags: needinfo?(past)
On Nightly I see the following before that error:

[Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIURIFixup.createFixupURI]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: resource:///modules/PlacesUIUtils.jsm :: PUIU_createFixedURI :: line 95"  data: no] urlbarBindings.xml:390:0

On fx-team I see only the above. I'm updating to check on fx-team tip.
Flags: needinfo?(past)
I can no longer see the message from comment 0 in either fx-team tip or the latest nightly. Could it be something that was already fixed?
Flags: needinfo?(gijskruitbosch+bugs)
(Reporter)

Comment 3

2 years ago
(In reply to Panos Astithas [:past] from comment #2)
> I can no longer see the message from comment 0 in either fx-team tip or the
> latest nightly. Could it be something that was already fixed?

I still see:

11:39:11.930 TypeError: docShell.failedChannel.securityInfo is null content.js:459:9

on latest nightly (Jan. 24, today's isn't out yet). Maybe this only reproduces with e10s off?

Either way, it still seems to me that we should change some of the assumptions here. Reading https://dxr.mozilla.org/mozilla-central/source/browser/base/content/content.js#385-396, it looks like SSL-related code now always run son about:neterror, even when the error isn't SSL-related at all.
Flags: needinfo?(gijskruitbosch+bugs)
(Reporter)

Comment 4

2 years ago
I can't reproduce this anymore, likely because a bunch of this moved to the backend.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.