silverlight not working under a non-e10s window

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

({regressionwindow-wanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8711146 [details]
issue.png

While testing the Silverlight blocklisting in bug # 1241237, I noticed that non-e10s windows under m-c indicate that Silverlight still needs to be installed despite working fine under e10s.

STR: (I also reproduced this on a Windows 10 x64 VM)

* Installed the latest version of Silverlight on OSX

> File: Silverlight.plugin
> Path: /Library/Internet Plug-Ins/Silverlight.plugin
> Version: 5.1.41212.0
> State: Enabled
> 5.1.41212.0

* Under e10s, opened [1][2] and was asked to activate Silverlight as it's set as "Ask to Activate" by default
* Opened the exact same pages under a non-e10s window via the hamburger menu and I was asked to install Silverlight (see attached screenshot)

[1] http://www.microsoft.com/silverlight/iis-smooth-streaming/demo/
[2] http://www.microsoft.com/silverlight/silverlight/demos/controls/default.htm

Comment 1

2 years ago
Maybe this is an issue with loading 32-bit plugins from a 64-bit mac host? Although if this can reproduce on Windows that's probably not the best theory.

Bill, might this be related to the plugintag updating issue you were working on?
Component: Silverlight (Microsoft) → Plug-ins
Flags: needinfo?(wmccloskey)
Product: Plugins → Core

Updated

2 years ago
tracking-e10s: --- → ?

Comment 2

2 years ago
Actually Kamil, are you trying this by disabling e10s and restarting, or just choosing the "new non-e10s window" option?

This is expected (WONTFIX) in the latter case, because we cannot run a plugin against the chrome process and the content process at the same time so we disable all plugins in the chrome process when we're running in e10s mode.
Kamil, can you try restarting with e10s off (Go to preferences and uncheck "Enable multi-process Nighly" in the "General" section)?

I don't think this would be related to bug 1231306. Let's see though.
Flags: needinfo?(wmccloskey)
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

2 years ago
> This is expected (WONTFIX) in the latter case, because we cannot run a
> plugin against the chrome process and the content process at the same time
> so we disable all plugins in the chrome process when we're running in e10s
> mode.

That's definitely the case.. It works without any issues once you disable e10s via the preferences and restart into non-e10s. Apologies for the false alarm ;)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
tracking-e10s: ? → ---
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.