Status

()

defect
RESOLVED DUPLICATE of bug 1145903
3 years ago
3 years ago

People

(Reporter: ivan.moren, Assigned: BenWa)

Tracking

43 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
Posted video ff_loadImage.mp4
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160107040617

Steps to reproduce:

I attached an mp4 with firefox performing on my Arch Linux system w/ GNOME 3.18.

1. Enter "https://upload.wikimedia.org/wikipedia/commons/6/67/The_unveiling_of_the_Wikipedia_monument_65.JPG" into the search bar and press Enter.

2. If the image was already in cache, press shift-ctrl-R to reload it.


Actual results:

The image is poorly scaled while being downloaded to the computer. After the whole image is downloaded, it snaps to the right scale. 


Expected results:

It should have had the same scale and zoom as it gets when fully downloaded.
Reporter

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: image is scaled while loading → Image is scaled while loading

Comment 1

3 years ago
Sorry but your MP4 video is broken, no video track.

IMHO, it's way how FF decode the image.

Updated

3 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core

Comment 2

3 years ago
Picture Orientation = rotated 90° (6)

FF follows this pec now.
Reporter

Comment 3

3 years ago
That is weird, for me the video is plaing in VLC and in firefox. I uploaded it to vimeo as alternative source though; https://vimeo.com/152805605
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 4

3 years ago
This is fixed by my patch to bug 1145903. Thanks to tn for pointing this out.
Assignee: nobody → bgirard
Assignee

Comment 5

3 years ago
I wrote about the debugging process of this bug here if anyone would like more details:
https://benoitgirard.wordpress.com/2016/02/23/using-recordreplay-to-investigate-intermittent-oranges-bug-2-part-2/
Assignee

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145903
You need to log in before you can comment on or make changes to this bug.