Closed Bug 1242097 Opened 4 years ago Closed 4 years ago

Support sync module for logging

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox46 --- affected
firefox47 --- fixed

People

(Reporter: billm, Assigned: billm)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
I've been using NSPR logging to debug some IPC crashes, but it's not too useful if the log doesn't get flushed on every write. The last writes are usually the most interesting. This patch adds support for the artificial "sync" module, which NSPR already seems to support.
Attachment #8711261 - Flags: review?(erahm)
Comment on attachment 8711261 [details] [diff] [review]
patch

Review of attachment 8711261 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, thank you for adding this missing NSPR feature.
Attachment #8711261 - Flags: review?(erahm) → review+
https://hg.mozilla.org/mozilla-central/rev/57e9eb4ed010
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Flags: needinfo?(wmccloskey)
Duplicate of this bug: 1244323
You need to log in before you can comment on or make changes to this bug.