Remote debugging not working: stays in Connecting state

RESOLVED FIXED in Thunderbird 47.0

Status

Thunderbird
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aryx, Assigned: aryx)

Tracking

({regression})

Trunk
Thunderbird 47.0
regression

Thunderbird Tracking Flags

(thunderbird45 unaffected, thunderbird46 fixed, thunderbird47 fixed)

Details

Attachments

(1 attachment)

Latest Daily. This is a regression from bug 1237602.
Comment on attachment 8711320 [details] [diff] [review]
patch, v1

Review of attachment 8711320 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing this review to get the debugger working again, r=philipp
Attachment #8711320 - Flags: review?(acelists) → review+

Updated

2 years ago
Keywords: checkin-needed
OS: Unspecified → All
Hardware: Unspecified → All

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 47.0

Comment 4

2 years ago
Fwiw, this wasn't broken by bug 1237602, there is no list comprehension here, just an incorrect Map.forEach callback.
Comment on attachment 8711320 [details] [diff] [review]
patch, v1

[Approval Request Comment]
Regression caused by (bug #): bug  1237602 
User impact if declined: Remote debugging not working
Testing completed (on c-c, etc.): Verified fix on c-c
Risk to taking this patch (and alternatives if risky): low (reverts to previous behavior)
Attachment #8711320 - Flags: approval-comm-aurora?

Updated

2 years ago
Attachment #8711320 - Flags: approval-comm-aurora? → approval-comm-aurora+

Updated

2 years ago
status-thunderbird45: --- → unaffected
status-thunderbird46: --- → affected
status-thunderbird47: --- → fixed

Comment 6

2 years ago
Aurora (TB 46):
https://hg.mozilla.org/releases/comm-aurora/rev/d5a354015782
(DONTBUILD, next Daily will puck it up).
status-thunderbird46: affected → fixed

Comment 7

2 years ago
s/puck/pick/
You need to log in before you can comment on or make changes to this bug.