CallNonGenericSelfhostedMethod should use the target method's name in the error message instead of the intrinsics'

RESOLVED DUPLICATE of bug 1113685

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1113685
2 years ago
2 years ago

People

(Reporter: till, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox46 affected)

Details

(Reporter)

Description

2 years ago
The (templated) CallNonGenericSelfhostedMethod intrinsic throws errors with messages such as "TypeError: CallTypedArrayMethodIfWrapped method called on incompatible null".

Instead, the string passed in as the last argument should be used.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113685
You need to log in before you can comment on or make changes to this bug.