calendar-month-view.xml, line 933: TypeError: can't assign to properties of (new Number(7)): not an object

RESOLVED FIXED in 4.8

Status

Calendar
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aleth, Assigned: Decathlon)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
On startup:

JavaScript strict warning: chrome://calendar/content/calendar-month-view.xml, line 932: TypeError: can't assign to properties of (new Number(7)): not an object
JavaScript strict warning: chrome://calendar/content/calendar-month-view.xml, line 933: TypeError: can't assign to properties of (new Number(7)): not an object
(Assignee)

Comment 1

2 years ago
Created attachment 8711441 [details] [diff] [review]
patch-v1

I can't reproduce the error message on startup, but since the property ChildNodes returns a list of type NodeList, I think that using the statement for ... in is wrong in this case.
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Attachment #8711441 - Flags: review?(aleth)
It is not an error, it is just a warning in strict mode.
(Reporter)

Comment 3

2 years ago
Comment on attachment 8711441 [details] [diff] [review]
patch-v1

Review of attachment 8711441 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8711441 - Flags: review?(aleth) → review+
(Reporter)

Comment 4

2 years ago
https://hg.mozilla.org/comm-central/rev/6f577ad0e636c1f8b6fb9379c3100f0204f912c8
Bug 1242200 - calendar-month-view.xml, line 933: TypeError: can't assign to properties of (new Number(7)): not an object r=aleth
(Reporter)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 4.8
You need to log in before you can comment on or make changes to this bug.