[DevTools][Memory] "Saving census..." does not end after switch to "Allocation Stack" with any filter words

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
3 years ago
6 months ago

People

(Reporter: magicp.jp, Assigned: fitzgen)

Tracking

(Blocks: 1 bug)

Trunk

Firefox Tracking Flags

(firefox44 unaffected, firefox45 affected, firefox46 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8711382 [details]
memory-tool-saving-census.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160123030348

Steps to reproduce:

1. Start latest Nightly
2. Open Memory Tool
3. Run "Take Snapshot"
4. Set any filter words (e.g. objects)
5. Switch to "Allocation Stack" from "Coarse Type"


Actual results:

"Saving census..." (throbber) does not end.


Expected results:

"Saving census..." (throbber) is completed without errors.
(Reporter)

Updated

3 years ago
Blocks: 1221506
Has STR: --- → yes
status-firefox44: --- → unaffected
status-firefox45: --- → affected
status-firefox46: --- → affected
Component: Untriaged → Developer Tools: Memory
OS: Unspecified → All
Hardware: Unspecified → All
(Reporter)

Comment 1

3 years ago
Created attachment 8711384 [details]
javascript-error-in-browser-console.txt
Assignee: nobody → nfitzgerald
Status: NEW → ASSIGNED
Priority: -- → P2
Priority: P2 → P1
This has since been fixed (can't find the bug, but I remember writing the fix), and it shows an empty table as expected if there is nothing matching the filter word.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.