Remove more stylesheet links to remove doubled CSS rules

RESOLVED FIXED in Thunderbird 47.0

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 47.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Like bug 1238289, now with scope of TB.

Multiple refereces to stylesheets makes the rules showing doubled or tripled in DOM. I'm not sure about this but I think this uses more memory and could slightly slow down TB. But cleaning this makes it easier to find the rules in DOMi.
(Assignee)

Comment 1

3 years ago
Created attachment 8711443 [details] [diff] [review]
removeStylesheetLinks.patch

I've found the cause for the doubled global.css rules. It was the link in chat-messenger-overlay.xul. Now TB should be cleaned up of this duplications.

Aleth, I added you because I also touched chat files.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8711443 - Flags: review?(philipp)
Attachment #8711443 - Flags: feedback?(aleth)

Updated

3 years ago
Attachment #8711443 - Flags: feedback?(aleth) → feedback+
Attachment #8711443 - Flags: review?(philipp) → review+
(Assignee)

Comment 2

3 years ago
http://hg.mozilla.org/comm-central/rev/e8a311fcbd37
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 47.0
You need to log in before you can comment on or make changes to this bug.