Toolbarbutton dropmarker has double border when pressed

RESOLVED FIXED in Thunderbird 47.0

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 47.0
All
Linux

Thunderbird Tracking Flags

(thunderbird45 fixed, thunderbird46 fixed, thunderbird47 fixed)

Details

Attachments

(2 attachments)

Posted image dropmarker.png
When pressing the dropmarker on .toolbarbutton-1 where is a second border around it. This is because of the -moz-appearance: toolbarbutton-dropdown from toolkit.
Use -moz-appearance: none and a icon for the dropmarker. The plus point about this solution is that we can use a inverted icon for dark LW-themes.

I also changed the height of the toolbarbuttons to 24px like on FX.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8711457 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8711457 [details] [diff] [review]
linuxDropmarker.patch

Review of attachment 8711457 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #8711457 - Flags: review?(mkmelin+mozilla) → review+
http://hg.mozilla.org/comm-central/rev/8e8225a7db71
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 47.0
Comment on attachment 8711457 [details] [diff] [review]
linuxDropmarker.patch

[Approval Request Comment]
Regression caused by (bug #): 1224818
User impact if declined: buttons are too fat and dropmarker has double border
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low, CSS changes
Attachment #8711457 - Flags: approval-comm-beta?
Attachment #8711457 - Flags: approval-comm-aurora?
The dropmarker on main toolbar buttons was actually lost in recent trunk on Linux (gtk3). Is this bug the cause or a fix for it?
With a local build from tip you see the dropmarker? On my local builds I've seen always a dropmarker. Please when you now don't see the dropmarker can you locally backout this patch to check if it is then visible?

Unfortunately where is no tinderbox build built with this patch applied.
Yes, with a local build from tip (some time yesterday) I see NO dropmarker. Whether I click it or not. The space for it is reserved to the right of the button.

I am not sure if I have this patch in it or not. Also my m-c is not completely updated so if there are any dependencies (like this bug fixing a problem introduced in m-c recently) that may be the answer to my problem :) I will investigate.
Attachment #8711457 - Flags: approval-comm-beta?
Attachment #8711457 - Flags: approval-comm-beta+
Attachment #8711457 - Flags: approval-comm-aurora?
Attachment #8711457 - Flags: approval-comm-aurora+
Beta (TB 45):
https://hg.mozilla.org/releases/comm-beta/rev/552fc6141938
Aurora (TB 46) will be coming.
Hmm, looking at the previous comments, perhaps I landed this prematurely, but I assumes Magnus, also on Linux, tested it.
OK, all is fine now with current tip. The dropmarker is back. Thanks.
Fantastic, thanks for the update, you had me worried. I'll land Aurora later today in coordination with Aleth, who might want to fix the Linux builds first as he's done on Beta.
You need to log in before you can comment on or make changes to this bug.